Data is missing

After migrating the elgg site script and database, every thing seems ok but for the files uploaded to server before migration e.g mp3 files do not download when clicked. No zaudio player is displayed.


  • Some other plugin might also not be compatible with Elgg 1.9 then. Disable ALL 3rd party plugins and then test again. Sort out all plugins that are not compatible with Elgg 1.9 (or update them at least if newer versions for Elgg 1.9 are available). I remember that you had similar issues a while ago when moving your data directory. And I'm pretty sure I gave you the same advice before. You simply can't use plugins that are not fully compatible with the Elgg version you have and expect that the problems vanish on their own. Either give up the plugins causing problems and look for alternatives or update them to work (or hire a developer to do it for you).

  • @iionly:Yes, you really were there to save me from trouble when I migrated from 1.9 to 1.10. I may need to do some things myself to learn about my property, for now. Thanks for your assistance. Sorry,its 1.10.12 version not 1.9. 

    I have deactivated the 3rd party plugins and still not working.I noticed that when i reverted to the backed up database, the site activity threads reverted to its status as at the last time the site worked. Apart from the 'datalists' table in the database, what other table should be edited to update the Iink between site script, database and the upploaded data? think there is yet another update required to point the database to the data saved in the data folder, because all uploaded contents are seen but cant be accessed.


  • There are two things to change:

    • path to data directory and
    • filestore data directory (that's an entry in the metastrings table).

    See for reference. But read the WHOLE guide about how to migrate an Elgg installation to understand what the instructions on changing the database entries mean (as you need to adjust the modifications according to your situation, i.e. servers paths).

  • Thanks I checked the metastrings table and updated the path to data root also , and under that field is a Filestore::Filestore but not sure if its the one you mentioned in statement "filestore data directory (that's an entry in the metastrings table)."


  • Do not edit the values in the database directly but execute the mysql command shown at to update the filestore::dir_root entry. You just need to provide the corresponding path to the data directory used on your server instead of the path shown in the string '/var/data/elgg_test/'.

  • I have reverted to a 2nd copy of the backed up database that was migrated, and ran the SQL according to the instructions on the page, as if I refreshly migrated and realised that the only photo i uploaded in the first copy of the database installed which showed and downloaded , is not reflected on the  2nd copy of the database connected now. I think  this issue is from the database. It is not connecting/ linking maybe to the files in the data folder. Are the urls not properly propagated?


  • If the backup you have used to restore the database was made before uploading the photo the database entries for this photo are missing now. Therefore, this image entry won't show on your site even if the image file is still in the data directory. There's no way to add the missing entries to the database (or let's say it would be quite likely that you break something when trying). Just upload the photo again. You could delete the image file from the data directory (including the thumbnail image file) but you could also leave them there as there's no harm in leaving them there.

    The more important question is if all the other images show up correctly now and if you can upload new images, too.

  • Sure I can upload new images, and the thumbnails show but the full files do not download. I read a thread  where a user recommended changing the time zone. The site was hosted on a server that ran PST/PDT while the present VPS is set at PST. I tried changing the timezone to "America/Los_Angeles" but there is a n error of UTC selected by elgg.

  • Timezone used was relevant in Elgg 1.8 and older because the structure of the users' data directories was organized depending on the date the users joined the site. On Elgg 1.9 and newer this is no longer the case as the users' directories are now sorted by user guid. And if the timezone would be the problem the image thumbnails wouldn't show up either and there wouldn't be an issue with the fullsize image files only.

    I don't know what kind of error showed up for you when trying to change the timezone. On Elgg 2 you can define the timezone used by Elgg in settings.php. On Elgg 1.12 and older this is not yet possible. Here you can either set the timezone server-wide in the php.ini of the server. Or you can set the corresponding php variable in Elgg's .htaccess by adding the line

    php_value date.timezone 'America/Los_Angeles'

    in the php settings block (in <IfModule mod_php5.c>).

    What exactly is the problem with the fullsize images? Is the Download link missing? There's a plugin setting to enable/disable this link. Or is the problem that the fullsize images are also not displayed? If you click on an image when viewing a single image the fullsize image should show in a lightbox popup. Does this work or not? If the download via the download link fails, the problem might be caused by another 3rd party plugin (try with all others disabled).

  • If the timezone is not the issue, then I wonder. The popup has not worked for the photos even before migrating from shared to VPS on a new host. The issue here is that no file is downloaded when the download link is clicked, and the mp3 player does not show again since the site was moved.I'll disable the only download counter.