Perdida de las marcas html

En un elgg que tengo instalado, al intentar destacar un grupo observo que se pierde todo el css. Miro el código y resulta que ha perdido las marcas html, head y body.

El recurso está en /misitio/elgg/groups/numero/nombre_del_grupo

Busco ese recurso en los archivos y no existe la carpeta /elgg/gropus. Por tanto no puedo arrglar el código a mano.

¿Alguna idea para solucionarlo?

  • Is the problem with the missing page layout happening only for this one group? Then it might be that this group has either some content or group member resulting in the error when it gets displayed.

    If you disabled a 3rd party plugin recently, this might be the cause of the error. Elgg might still try to display some content created with this plugin and fails to do so with the plugin no longer available.

    Or a 3rd party plugin you are using has a bug causing the error. In this case it might help to disable the 3rd party plugin temporarily to find out if the error still occurs then. If not, you would need to find out which plugin is causing the problem. Enable the 3rd party plugins again by one plugin at a time to see when the error shows up again. Knowing the plugin causing the error will help to debug. Without knowing the plugin it's nearly impossible to give any specific help.

    Or there might be some invalid entry in your database (either a content entity or a member entity). You can use the Database Validator plugin to check your database (and in case it shows errors use it to fix them). For Elgg 1.x use the version available at https://elgg.org/plugins/438616 and for Elgg 2.x use the version available at https://github.com/Elgg/dbvalidator. Do a verification run first and only make a repair run if there are any errors found (and before doing a repair backup your database).

  • Sí, el problema es sólo con un grupo.

    Usando firefox developer copio head de otro grupo y lo pongo en  este, funciona bien.

    Si pudiera acceder al código de la página, podría arreglarlo a mano. Pero no existe la carpeta /elgg/groups

  • Sorry. I don't fully understand your latest posting. I don't understand Spanish and Google translate doesn't give a good result this time.

    What I understood is that the error occurs only in one group and you are asking for how to change the code. This won't work. The error is not caused by a bug in code or the problem would occur on all groups. The problem must be related to a content entry or a group member entity of the group that shows the problem.

    As I outlined in my last posting, test if the error is caused by a 3rd party plugin - either a plugin you removed (which you would need to add again) or a plugin currently in use (test if the error still occurs with all 3rd party plugins temporarily disabled).

    You can also look into the server logs (Apache error log and/or php error log) if there are errors logged at the time of trying to view the group page. Such an error log could give additional information about what is wrong. And you should check your database for errors using the Database Validator plugin.

  • Me pasa lo mismo. Yo no hablo inglés y uso el traductor.

    No sé como usar el plugin de reparación de bases de datos. En el cpanel tengo una utilidad para ello. Dice que está correcta.

    Este es el sitio donde ocurre. En este grupo. Es un grupo cerrado. No encuentro el botón para editar el grupo y abrirlo (se visualiza muy mal). Piden entrar en él y te doy de alta

  • I see you are using Elgg 1.8 (That's a very old version... I suggest to upgrade to a newer Elgg release if you can, i.e. if the plugins you absolutely need are available also for newer Elgg versions. Best would be to upgrade at least to Elgg 1.12. Such an upgrade would have to be made by upgrading to 1.9, then 1.10, 1.11, 1.12. Just a sidenote).

    The Database Validator plugin is an Elgg plugin that can check (and repair) some issues that might occur with the database of your site. The database can still be fine as such but it might have some invalid entries that could result in problems. For Elgg 1.8 the version of Database Validator to use is 1.4 (https://elgg.org/plugins/438616/releases/1.4). Install the plugin like other Elgg plugins. In the admin section of your site you will find a new section then (at "Administer" - "Utilities" - "Database cleaner"). Here you can test your database for errors with "Validate". In case there are any errors found, make backup of your database and then you can do a "Repair".

    I don't know if this will fix the error that shows in the group. Maybe the error is caused by the access settings of this group (closed group). Do you also get the error when logged in to your website as an administrator? Is it possible for you to find out if one of the latest content added to this group causes the error?

  • Tengo miedo de actualizar la versión y que se estropee el sitio.

    Ya instalé el plugin. Dice que las bases de datos están OK.

    El administrador y un usuario básico ven mal el grupo.

    El grupo cerrado se veía bien. Cuando pulse en Make featured se estropeo.

  • iionly:

    Muchas gracias por tu ayuda. Crearé un nuevo grupo y volcaré en él lo que había en este.