Tags with non-ascii (international) characters don't work after upgrade to version 1.6

After upgrading from version 1.5 to 1.6 clicking on tags with non-ascii characters yields no results (was ok in 1.5).

First after the upgrade tags didn't work at all but after applying the .htaccess fix from 


then tags only with letters from the English alphabet do work as expected but tags with letters as áéóúíðþæö still don't.

What might be causing this and how can I fix it?

  • just confirming that I'm seeing this bug on my 1.6 dev site too.

  • Applying the fix in https://trac.elgg.org/elgg/changeset/3446 doesn't resolve the international character issue with tag searches introduced in v1.6 - clicking on tags with those characters still gives no results.

    Is there anything else I could try?

  • Would it be advisable to revert to the 1.5 source tree where this was OK?  

    I do have a copy of the tree from before the upgrade to 1.6 but as I ran the (database?) upgrade script I'm wondering if things would go seriously wrong if I'd go back to 1.5 after that upgrade?

  • trac fix has solved the prob on my site.

  • ...so I reverted the site back to the 1.5 tree and things seem to be working fine (I'm doing this with a live site, which of course I shouldn't - will do an upgrade to a dev version next time : )

    One thing I noticed that may help debug this (I've tried looking into the code but haven't seen any obvious causes):

    An item created with version 1.6 active, with a tag containing non-English characters, didn't come up in search when I had reverted back to 1.5 (though older items did).  Choosing to edit the item and saving it without modifying anything had it come up in search results.  

    Maybe I should file an official bug report or are you guys already onto this?

  • Susan:  Does it solve problems with tags containing non-English characters?

  • @bthj  - yes it did on my site which is in Hebrew

  • Did you do anything other than adding the four lines listed at



    I've done that and indeed search for tags with just english letters works fine, but not with extended characters.  Running the same site form the previously used v1.5 tree fixes the tag search problem but introduces others like erros when bookmarks are created, so I guess I'll have to stick to the 1.6 tree after the upgrade and figure out how to correct this problem with extended character tag searches.

    Any hints to what else I might try would be greatly appreciated.

  • @bthj - I don't know if this could be the reason but I am using jimbob's customsearch on my site


  • @Susan:  Thanks - I installed that plugin and followed the installation instructions but then tag searches don't work at all (but the new Fulltext search works fine, with extended characters).

    So I think I'll keep that plugin disabled for now, though it does indeed provide an interesting functionality, and hope someone can help me figure out this tag-search-with-extended-characters issue in v1.6 ?