Requirements check - Elgg requires the PHP extension mysql.

Requirements check

Your server failed the requirements check. After you have fixed the below issues, refresh this page. Check the troubleshooting links at the bottom of this page if you need further assistance.

PHP

  • Elgg requires the PHP extension mysql.

  • Just install all requirements:

    apt-get install php5-common php5 libapache2-mod-php5 libapache2-mod-auth-mysql php5-cgi php5-mysql php-image-graph imagemagick php5-cli php5-curl php5-gd php5-mcrypt php5-memcache

    Read more on Elgg Docs

    If you want to install the latest PHP >= 5.5 and MySQL 5.6 then read this page also