Login Problem again and again?

Why is it asking again for login just after a minute or when user did anyone activity being already logged in and then it shows login page again.Also,while log in it says not allow to login from different domain.What's the fault???

  • Sorry,I didn't understand..what you want to say about new plugin

  • Sorry,I didn't understand what you want yo say about new plugin

  • I think the question has been if you recently installed any new plugin(s) that might cause the problem. So, have you had this problem since the beginning or did it work in the past and only started to fail recently (e.g. after updating either Elgg to a new version if you ever did this or after adding / upgrading some plugin)?

    Which version of Elgg are you using anyway?

  • @rohit,iionly,juho,Ismayil,

    yes I think the problem is with url,I did http while installation but I regitered it without http with my host.I have this code,please tell me,where should I paste this code in .htaccess. or should i make any changes or what.Please help me.

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{HTTP:X-Forwarded-Proto} ^https$
    RewriteRule .* http://%{HTTP_HOST}%{REQUEST_URI}</IfModule>


  • sorry,I think the major mistake I have done is that,,,,,,,,

    I have my data directory in application folder and i have given my path for data directory in public_html.

    Please help me,How can I cange my path of data directory.

    Looking forward for fast reply.

    Thanks in advance

  • I am hesitating to change it from admin advanced settings.

    Should I change it from there.

    Please help.!!!!!!!!!

  • I am giving my site url please check it.


    Log in as-:



    Please help me..!!

  • Change The Data Directory from the admin settings page but be sure to have created the folder you have specified.
    Plus, upgrade need to specify the complete length of the address.

  • If you only started with the site, i.e. no important content on the site yet, it might be the easiest approach to start fresh and to do it right from the start this time.

    While you can change the site url and the paths to Elgg install directory and data directory on the settings page you can't change the so called filestore entry in the database from the settings page (which is normally the same as the path to the data directory but would have to get updated on moving the data directory, too). There's an explanation at http://learn.elgg.org/en/2.0/admin/duplicate-installation.html#database-entries telling you how to update the corresponding database entries directly in the database (for example with a tool like phpMyAdmin). The instructions are aiming at situations where you move your site or want to create a duplicate installation but of course the same works also when just moving the data directory or when it's necessary to correct a mistake in the site url or path to install directory entries.

    But again: if you haven't added important stuff to your site yet and there are not yet any users on the site it might be the easier approach to do a fresh installation. In this case make sure that you enter the correct site url this time (only use https if the server supports it - otherwise don't even try; best would be to also include "www" in the site url if you don't install your site in a subdomain - http://www.4linkers.com looks right to be used as site url). Also make sure you have the data directory created before starting the installation and that the permissions of the directory are correctly set.