Updating a theme to v1.5

I've heavily modified a theme to suit my purposes and somethings are as expected not falling straight into place now I've gone to v1.5


I wonder if somebody with the required knowledge might give us a guide to where the main areas of change will be needed.

Whether any files have changed where they live or, theming wise, whether there are new things to consider.



  • Cheers Dave, look forward to it.

    Great work you've all done on 1.5, thanks.

  • Hi, I have posted a few quick steps here that might help.

  • Hi Pete,

    I'm an elgg newbie and my task is to implement a custom theme for elgg. We've opted for 1.5rc2 for several reasons. I've created a folder mod/mytheme/ and copied the views folder in there. The idea is to work with view overloading, allthough through copying initially all the views are "overloaded" with the default version, but can then be modified to suit my needs view by view. In mod/mytheme/ I've added the manifest.xml and start.php as described in the elgg themes documentation. Start.php contains nothing but the mytheme_init function and the call to register_elgg_event_handler. Once I've activated the theme my changes to css can be seen but all the widgets on the start page refuse to work, i.e. Users online shows the loading animation and keeps doing so indefinitely. Where did I go wrong?

    I'd appreciate any help!

    Cheers, Jens

  • Sounds like a JS problem.

    Is your Tools dropdown working at least?


  • Hi Kevin,

    you're right, the dropdown doesn't work either- and I'm not familiar with jQuery... There's no JS-Error firebug would tell me about. Interestingly I can customise the Dashboard by dragging and dropping widgets  from the Widget Gallery. Obviously I have to dive a lot further into how elgg works to understand what's going on. Still I wouldn't mind any further suggestions though!:)

    Cheers, Jens

  • Wait a minute, firebug wasn't configured properly. It does indeed throw an error: $("a[rel*=facebox]").facebox is not a function. The function is called in line 22 of the dashboard HTML-Output. Probably not all of the necessary JS-Files included? I'll compare the output with and without my theme activated and hopefully geht a hint as to what's missing.

    Cheers, Jens

  • @Jens

    re: the"error: $("a[rel*=facebox]").facebox is not a function."

    have a read on this post here -- http://community.elgg.org/mod/groups/topicposts.php?topic=25765&group_guid=23300


  • Hi Dhrup,

    the thread suggests that whether or not the JS works has something to do with the format of the URL of the JS-file. Id' be happy if this'd be the solution, but JS works flawlessly without my theme on our server. Only if I activate the theme I get the error. I suppose there's some other mistake I've made. Nevertheless I've tried if getting rid of /<?php echo $vars['config']->lastcache; ?> helps- but it didn't. Am a little clueless right now.


  • Problem solved. It somehow was connected to the simple caching mechanism. I'd turned it off and on and off and on and nothing changed. I'd tried the solutions from the thread Dhrup mentioned. Again nothing. Eventually I simply deleted the files in elgg_data/views_simplecache/... Et voila! Now I've switched caching back on again, switched between themes and everything works just fine. No idea what the problem was, couldn't find any hints in the server logs. Kevin and Dhrup, thanks for pointing me in the right direction!


  • @Jens

    good 4 you ;-O

    There's a fix going into v1.5 to take care of this silly JS trouble caused by some servers...