Version 1.6 is now the latest download

I just noticed that the latest download is now V1.6.  I'm about to try this new release out.  I've you've installed this final release (not the previous RC1), please post your comments here.

  • It's very strange! It says "RELEASED AUGUST 09" but this morning the RC1 was there.

    And why not a RC2?

  • Green Elgg and Bam! - just downloaded, created a new database, created the upload directory, set permissions, and bam, Elgg 1.6 is running on an existing virtual machine where I have other Elgg instances. 

    Haven't done much other than enabling all plugins and logging in.  So far - it's smooth sailing...

  • For me it's more important to test the upgrade from 1.5 instead of a clean install 

  • In case anyone want to test and see what vanilla 1.6 looks like - from a clean install, you're welcome to visit this test site:

    Warning - Be gentle! it is running on a Sheeva Plug Computer.

  • Hi Dave, thanks for your reply. I agree if there were no serious issues reported, so, there was no need for an RC2.

  • Lets wait until people talk about plugin compatibilities.

  • The packaged plugins seem to be working but need more test.  I've tested the group file permission and working well.  There is an odd behavior that when the group admin changes the permission of a group file to a group that the author does not belong to, it sets the permission to private rather than just leaving it alone.

    So far, I tried wavatar, izap_videos_improved and they seem to be working ok.

    I've also done an upgrade from 1.5 instead of just a new install and that worked ok as well.

    Please let's not wait for each other - simply post what you've done to help move this along.  This is about all of US working in concert, not some invisible dude we need to wait for.

  • BTW, anyone interested about plugins and 1.6 may want to cross reference this group:


  • We've converted our test site to 1.6 from 1.5. No problems so far. We're using the SimpleNeutral Theme. All is well. Have seen no differences, yet. Other than the standard plugins, we're using izap video, site access and tidy pics. Test site doesn't have much data presently. Will be loading it up and see where it goes. Be back soon.

  • We are getting an error message upon registration. This is a 1.6 from 1.5 upgrade. We have verified it in 2 different sites. It happens with SiteAccess on and off. It happens with our theme on and off. It happens with uservalidationbyemail on and off. It happens with captch on and off (siteaccess off for both). The registration comes about fine. The emails are sent fine. The validation is fine. The user is created and valildated just fine. Everything works except right after the user presses the Register button, he get this error message ...


    Failed to load new ElggObject from GUID:79

    Then, for each registration the GUID number changes. For example, the next registration the error is...


    Failed to load new ElggObject from GUID:100

    The next is...


    Failed to load new ElggObject from GUID:121

    etc, etc, etc, etc.

    The url that is displayed is

    Can someone give a lead as to what is going on here? What else shall we check to narrow it down? It's consistent and happens 100% of the time on both sites. It did not ever happen in 1.5. Where shall we look, what shall we do next?


Feedback and Planning

Feedback and Planning

Discussions about the past, present, and future of Elgg and this community site.