Configuring elgg with XAMPP

I'm having an issue that I started in this thread. I thought I'd create another thread and sum up what I've figured out and what's not working. I'm working with lakewylieboating.com . The site comes up fine locally, either through localhost or viewing the domain by pointing to the tld "http://www.lakewylieboating.com"  Trying to access the site externally I have serious delays in bringing the site up.  I know this is a configuration issue either with DNS or apache config. Does anyone know where I can start with this. I'm getting

[Sun Aug 23 12:07:21 2009] [error] [client 75.176.18.130] DEBUG: 2009-08-23 12:07:21 (CDT): "Undefined index:  id" in file C:\\www\\lakewylieboating.com\\community2\\engine\\lib\\sessions.php (line 448)

not sure if the undefined index has anything to do with this issue.

 

  • the apache access log.

    75.176.18.130 - - [23/Aug/2009:12:55:39 -0500] "GET / HTTP/1.1" 200 1382
    75.176.18.130 - - [23/Aug/2009:12:55:39 -0500] "GET /vendors/jquery/jquery-1.2.6.pack.js HTTP/1.1" 304 -
    75.176.18.130 - - [23/Aug/2009:12:55:39 -0500] "GET /vendors/jquery/jquery-ui-personalized-1.5.3.packed.js HTTP/1.1" 304 -
    75.176.18.130 - - [23/Aug/2009:12:55:40 -0500] "GET /_css/js.php?lastcache=1251048576&js=initialise_elgg&viewtype=default HTTP/1.1" 200 3985
    75.176.18.130 - - [23/Aug/2009:12:55:40 -0500] "GET /_graphics/powered_by_elgg_badge_drk_bckgnd.gif HTTP/1.1" 304 -
    75.176.18.130 - - [23/Aug/2009:12:55:40 -0500] "GET /_css/css.css?lastcache=1251048576&viewtype=default HTTP/1.1" 200 10514

  • ok I give up on elgg until this is fixed. I know there is nothing wrong with my configuration, I'm doing just fine with plenty of other PHP/mysql apps and this is the only one that gives me this issue. I've heard one person say there running on the same platform but doesn't care prove this so i'm skeptical. I'll hope this is fixed soon. Oh BTW,  I've installed elgg on it's own machine only running elgg and the same issue.

  • @Lloyd

    17 days ago.. you posted your problems on

    http://community.elgg.org/mod/groups/topicposts.php?topic=218812&group_guid=12

    Perhaps you did not notice that the best of the best in regard to Elgg knowledge were trying to help you. The advice and helpful posts for your problem became a trickle because... you seemed to be *not quite listening and paying attention to the technical analysis of that problem which some very knowledgeable people were offering and you were quite openly not doing what was being suggested to fix your performance problem.

    I had asked you quite politely to give acces to your server so that one on us - armed with more knowledge in Elgg and apache server configuratiopn - could go in there and most likely in maybe minutes find the cause.

    You never reciprocated and you never opened up to the help that was given... ;-)

  • @Lloyd -- I just installed Elgg 1.6 and the latest version of Xampp through vmware on my mac.  The problem didn't exist for me so that indicates there IS something wrong with your specific server configuration or Elgg configuration.  This could be due to bugs in Elgg, bugs in your version of xampp, DNS issues, or a hundred other things in between.  This isn't something Elgg can fix because it isn't something anyone else can duplicate...we don't even know if the problem IS Elgg.

    @Dhrup -- I disagree.  Lloyd gave plenty of information.  No one should be faulted for not giving away server access.  I would *never* give my server credentials to someone I don't know well...It's just too risky.

    His problem is unique, and we've sent a few private messages back and forth and he's included the php.ini and apache.conf files.  He says he followed my last suggestion of clearing out the installation and trying Elgg by itself and is still having problems.  At this point what's left to do?  It didn't work on a clean install of xampp and Elgg.

    There's a possibility that Xampp + Elgg + Windows Server 2003 causes this problem.  I can't test this because I don't have Windows Server 2003.  First rule of bug fixing is that you're limited to what you can fix by what you can duplicate.  I can't duplicate this, so unfortunately I can't fix it.

  • In my experience with XAMPP on XP is that it makes a great local development enviroment for ELGG but if i use it for something more then local, it really bogs down. but... I run it on a laptop and this would never do as a production server.

    So i have never really thought about what to do in this situation, other then I use a linux VPS when wanting something to be public.

  • @Brett

    apologies...

    hee needs to figure out why his server does not seem to satisfy / allow the aspects elgg expects - this can be seen quite clearly thru LiveHttpHeaders - his site's headers are different to other Elgg sites ;-( ==> his server is doing some kind on overrides ;;; praps he might want to test out a live linux/xampp test server to see.

  • two things i don't think anyone has suggested or you have said you have tried is looking at

    my.cnf file in the xampp\mysql\bin

    see what kind of resource allocation there is

    and

    try adding this Win32DisableAcceptEx to apache\conf\httpd.conf file on the last line

     

  • We know it's not a database issue.

    To recap from the other thread, the issue is that there is a 30 second pause between outputting the CSS and get the final TCP/IP ACK from the server.  In this time the browser is spinning away, not parsing the page because it thinks there's more coming.  It's 30 seconds each time so this indicates a timeout somewhere.

  • @Lloyd -- try this:

    in _css/css.php change line 37 from:

            header("Content-type: text/css", true);

    to

            header("Content-type: text/javascript", true);

    That won't make the CSS display properly but might give an indication if someting is off with the server.

    _css/css.php and _css/js.php operate exactly the same except for this header (and the actual content, but that's another story.)  Once you've made that change, try going to http://www.lakewylieboating.com/_css/css.css?lastcache=1251288359&viewtype=default and see if it loads quickly.