Old plugins work on latest version

Do old plugins work on 1.12? I see version 2.0 listed on plugins' page. Version 2.0 is not on the website.

  • Do old plugins work on 1.12?

    All Elgg plugins > version 1.9

  • You mean only greater than 1.9? or 1.9 work as well? There are 4 plugins which are giving an error in plugin list. Fatal error in exception handler. Check log for Exception #1447602526

    What is it?

  • Assuming you are using Elgg 1.12 you should be able to use plugins releases that were recommended for Elgg 1.10 - 1.12. Even (almost all) plugins releases recommended for Elgg 1.9 should still work on Elgg 1.12. With plugins releases recommended for Elgg 1.8 it's less likely that they work on Elgg 1.9 - 1.12 but some might still do. Any plugin releases made for Elgg 1.7 or older are not recommended to be used on Elgg 1.8 or newer anymore (changes in Elgg core were just too extensive).

    If a plugin release has been recommended for Elgg 2.0 only, don't try to use it on any Elgg 1.X version. In this case it's for a reason that the plugin release has no longer been recommended for Elgg 1.X. It won't take long anymore until the final release of Elgg 2.0 will get published.

    Best would be to use the plugin release recommended for your version of Elgg exactly. If there's no such release try the plugin release recommended for the closest older Elgg version (in case of using Elgg 1.12 back to Elgg 1.9 at most).

    The exception numbers don't tell you what it wrong but only when the error occured (the number is a unix timestamp). All these kind of fatal errors are logged in the server log (check the Apache error log or the php error log in case php uses a separate log file). The corresponding entry in the log will also include the exception number, so you should be able to find the entry.

  • thank you for a detailed answer