Admin account after install

After Elgg has installed, and the area where one would usually create their 'admin' account, all I get is a blank page, and also if I try and register.


I did manage a successful install, however, I managed to 'break' it with a mod, or the mod managed to beak it, either way I deleted the elgg directory, database and any relevant stuff, downloaded elgg 1.5 and that happened. Also tried 1.6 but still the same. My first guess would be some sort of missing php extension, but, last I checked, it meets the requirements.

Also should add, I've tried uploading elgg in several ways, FTP and cPanel mainly. And also tried downloading Elgg a few times.

  • eeeeeecchhhhhsssshhhhh !!!! LOLZ ;-)

    post some more details re: what you're doing, how comfy you're with the  techie aspects - php, mysdql, apache... and 'someone" will look into that.. as long as you maintain your sense if humor ;-) b/c we can be a "pain" sometimes...

    First piece of advice -- once you install OK  - do *not *rush in and enable **all PlugIns. I just did that to my local PC Elgg and screwed it up a few hours back... needed double-bypass elggurgery to recover...;-)


  • You've given me an idea, though not sure how, going to try it out on MAMP as I have it installed for testing purposes, and yes I have read the bit about MAMP in the Docs ;)

  • aha ;-)
    so you're testing on yr MAMP platform on yr MAC ?
    Now you're giving "better" info...
    It is things like that matterwhen someone else tries to help..
    We need to know the target environment - every little detail will help.
    ( ps: I know friends who have Elgg on MAMP at home Mac... w/ n/p )

    Let us know how you go, even if we don't know Mac/MAMP - we kinda do know "Elgg' a *little ;-)

  • Interesting... I had an Elgg install on there before, which worked as far as I knew, so I put in a new one, new directory, new database etc. and it some-how copied over a mod I had which enabled me to change the copyright stuff. Which doesn't totally make sense to me. But anyway, on the original working Elgg I had on the live install, I had disabled registration in the settings.php, so, could that be the reason why the registration isn't working?

    I'm thinking this may just be because I put the new MAMP install in a sub-directory of the original, going to try moving the old one temporarily and see if it sticks.

    And also, MAMP is just for testing purposes, the live one is a host I've paid for. The target is pupils of the school I kinda work for, so a social network just for them, no pedos allowed. You know.


    UPDATE: The copyright stuff didn't stick after I moved the original, so based on that, the fact registration was disabled on the live shouldn't have any affect on the new one, as it was deleted. I have a good feeling about checking the .htaccess for some reason :s

    UPDATE 2: .htaccess is empty, so nothing there. Btw, registration does work on the new MAMP install, so I'm guessing it's a server issue, so I need to look at everything my MAMP server has, and everything my host has and compare. Fun. Also tried deleting browser cookies and the cache on a whim to no avail.

  • Hmm, I was thinking, since I dont need registration anyway, it wouldn't be entirely impossible to manually add an admin account to the database, at least then I may be able to login and see if there's anything else that doesn't work, which may give some clue as to the problem.

  • Thanks for the links =)

    Now, I copied the elggusers_entity table from the working MAMP install to the not-working live install and I couldn't login. Is this expected from such a maneuver? Are there other tables I should have copied over? Or is this a sign that logging in doesn't work either?

  • You *are *in *my *galaxy now ;-)  ... believe this..!
    PLZ explain -- how you did that "copy" of the tables...?
    inch by inch..
    And maybe.. I will see what's missing ;-)

    ( I already have a suspicion...;- )


  • Just used phpmyadmin, exported the table on the MAMP database into a .sql file imported into the live one by uploading said .sql file, deleting the original first. Pretty much what I did.

  • ???
    more details ;-)
    'users" are stored on *** 2 tables
    users entity
    if u wanna play at the low db level -> need data for users from both tables, but only *user id data - 8no other entity data...
    make sense ?