Deleted/Reinstall User Dashboard Folder now Forbidden 404

Hi all, I've searched all over but cannot find a solution to my problem.  

I deleted my dashboard folder when I was troubleshooting a WSOD situation on that page, so that I could do a fresh upload of it and activate it new.  However, when I do, it now gives me a:


You don't have permission to access /dashboard/ on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

error.  I've tried everything I know, short of reinstalling the entire thing, and it still thinks its a actual directory. Is that the only way? what a bummer if so... I can activate it in the admin and all but cannot access the area from the front.  Does anyone know how to get around this?  I deleted the core profile plugin one and it reactivated fine, because I had the WSOD there too, but that one I was able to access fine.

Any clues?

Thank you in advance,




  • Of course, this is what is in the error log, but I don't know how to work around it.

    "Directory index forbidden by Options directive:"

  • It's a permissions issue? You can try and set that folder's permission to a user that has sufficient permissions.

  • Hi thanks for answering, yeah, I tried that, no dice. Made it the same as stock and also made them 755 still forbidden with that error.

  • I also should state that I inactivated all non-core plugins and still errors, even after deleting and re-uploading and reactivating multiple times. strange.

  • Post your error logs.

  • Here they are thanks for looking, as you can see I don't have a 403 set up but those are the only errors from that session, after I disabled all non-core plugins, not much to glean huh? btw its actually 1.8.19, if that matters any:

    [Fri Oct 09 11:45:26 2015] [error] [client] File does not exist: /home/gohele/public_html/mysite/elgg-1.8.17/403.shtml, referer:
    [Fri Oct 09 11:45:26 2015] [error] [client] Directory index forbidden by Options directive: /home/gohele/public_html/mysite/elgg-1.8.17/dashboard/, referer:
    [Fri Oct 09 11:45:23 2015] [error] [client] File does not exist: /home/gohele/public_html/mysite/elgg-1.8.17/403.shtml, referer:
    [Fri Oct 09 11:45:23 2015] [error] [client] Directory index forbidden by Options directive: /home/gohele/public_html/mysite/elgg-1.8.17/dashboard/, referer:


  • Either the main httpd.conf or the .htaccess file in this directory or a nearby parent directory probably includes:

    Options -Indexes

    Your host may have to set it to +Indexes if you don't have access in .htaccess and want to list the directory, absent a default index.html, index.php, etc. If the directory should not have a default file and you don't enable Indexes, you may only directly target the the filenames.


  • yeah I saw that too, and my .htaccess is the same as its always been with -Indexes and I thought perhaps an .htaccess got into the dashboard directory by mistake, but no, just the views and languages folders. I am at a loss, I think I am going with the AU sets anyways, and leave the dashboard disabled.  Its still eating at me though...

  • …along with the start and manifest of course.

  • Check the permission AND owner and group of the files and subdirectories of the dashboard plugin that you re-installed. Most likely something isn't right here and the webserver just can't read these files.