Major issues!

Firstly it worked fine, Images, Avatars etc all showing.....

I then tried adding a few new photos (tidypics Plugin), They seemed to be going fine but then, the page didnt redirect to the photos as it usually does?

So i go into my softaclous panel to see it Elgg needs upgrading to next version(You will be Upgrading to : Elgg, Version : 1.12.4) but when i hit the upgrade button i get The following errors were found :

Required PHP extension not found : mbstring

So i dont know what to do apart from back up what i have can anyone point me in right direction please??


Thank you kindly....



  • As ive said at begining they were all fine, then a user tried infront of me to upload some photos, they uploaded didnt not display this is when i noticed all starting(now resolved errors).. Ive just caught up with this thread and im gonna try the dir/perms as some1 has explained.

    Thanks for the input so far and i will let you know how its going etc etc..

  • So as i eat some food as im losing energy trying to resolve this LOL, yup still in same boat.

    Gonna post some details:

    Server disk space usage: 126.75 MB / 1.95 GB (so dont think this is issue)

    AS ive said they were there, now im getting no photos but there tags etc displaying and can upload but nothing shows...Avatar image is just a Question mark...

    Copyright: iionly 2013-2015, Cash Costello 2011-2015
    License: GNU General Public License Version 2
    Location: /home/teacosyb/public_html/CanalCommunity/elgg/mod/tidypics/


    Type Name Expected Value Actual value Comment
    Requires Elgg version >= 1.10.0 1.12.4 OK
    Suggests Plugin: widget_manager Any 5.1 OK
    Suggests Plugin: elggx_fivestar Any 1.10.10 OK
    Suggests Plugin: elggx_userpoints Any 1.10.13 OK
    Provides Plugin: tidypics 1.10.6 -- OK


    Anymore info needed to help please let me know..

    Thanks guys and gals..

  • Which Elgg version have you updated from?

    Have you run the Elgg update after updating the Elgg version ("Upgrade" button on Elgg's admin dashboard or running Do you see any updated pending on the "Configure" - "Upgrades" page in the admin section of your Elgg site? If you have upgraded from an Elgg version older than 1.9 directly to 1.12 (which you shouldn't do anyway) it could be that there are some pending updated included migration of data directories. This would explain why existing images do not show up.

    If uploading new images fails - and not only Tidypics images but also avatars - it could be that either the permissions of the data directory are suddenly not correct anymore (webserver can't read and/or write to the data directory) or that the GD php extension is either no longer installed or not working correctly. The GD php extension is used by Elgg core for creation of avatar thumbnails and also used by Tidypics if no other image library is selected in the Tidypics plugin settings. You could check on the "Server information" tab of the Tidypics plugin settings of the GD php extension is available.

    You might also want to ask the support of your webhost to take a look at your installation. They might be able to find out what exactly might have gone wrong on updating your site.

  • Ok so upgrading, is all done by the softaculous software auto installer/upgrade. I have done 3 upgrades prior this way and everything was fine. Checked the perms on dirs etc nothing has changed in there to my eye, but just to be sure:

    What should be set to what CHMOD Values please, thanks for your input iionly...heres where i am at with server:

    Server Information

    PHP Version 5.5.30  
    GD Enabled Elgg requires the GD extension to be loaded
    imagick Disabled  
    exec() Disabled Required for ImageMagick command line
    Memory Available to PHP 200MB Change memory_limit to increase
    Memory Used to Load This Page 12.87 MB This is approximately the minimum per page
    Max File Upload Size 2MB Max size of an uploaded photo file
    Max Post Size 8MB Max post size = sum of photos + html form
    Max Input Time 60s Time script waits for upload to finish
    Max Execution Time 300 s Max time a script will run
    GD imagejpeg Enabled  
    GD imagepng Enabled  
    GD imagegif Enabled  
    EXIF Disabled  


    So as this suggests nothing has changed?? maybe im missing something...I really dont understand image uploads do not fail it says 'succesfully uploaded' but then nothing shows...Gotta be something with perms im thinking but nothing looks like it has changed....

    Once again ty all for input...

  • OK looked at this and yep all my values are correctly set where does the pics go in dir sense?

  • Try to disable elgg cache then run upgrade.. Sometimes the cache can also cause this problem..

  • yes i just tried this and nothing either on or off?? STuMpEd :/

  • Three cases:

    1. uploading of any type of files fail,
    2. uploading of images (including avatars) fails,
    3. Tidypics image uploads fail.

    For case 1 I would suggest to use a small pdf or txt file for testing (smaller than 1 MB in any case). Try to upload it to the Files section of your site (bundled Files plugin would have to be enabled for this to work). Does the upload work and can you download the test file again? If this fails, the likely reason is that the permissions of the data directory are incorrect and the webserver can't save the files even. In this case you would have to change the permissions of the data directory (and all subdirectories within!) either to 777 or you would have to change the permissions for example to 755 AND change the owner of the files and directories to the account the webserver runs on. If it would still fail to work with uploading / downloading arbitrary files it might be that your php ini uses the open_basedir directive and the data directory isn't included in the list of allowed directories.

    Case 2: if you can upload any files but uploading images / avatars fails it could be due to the value of post_max_size in .htaccess. Currently it's set to 8M (default) and this value might be too small to handle the resizing of images. Max size of file uploads is also limited to 2M by upload_max_filesize in .htaccess. While you might not want to increase the limit for file uploads I would suggest to increase post_max_size in .htaccess nevertheless. Try it for example with 64M in .htaccess of Elgg, i.e. change the corresponding line where the post_max_size value is set to:

    php_value post_max_size 64M

    If uploading and display of Avatars (or images uploaded to the Files section) works, case 3 with Tidypics should work, too, if you use the GD php extension as image library in the Tidypics plugin settings. The other two image libraries won't work because Imagick and the exec function are both not available on your server.

  • OK so this is where i am upto amongst all this mess LOL :) Uploading files works, downloading files works but when you try view the file it says error on viewing(this is a simple pdf). So ive increased the php_value etc etc and just trying alot more to get this back to normal....

    Thanks all for the help and keeping me sane :)

  • Nope dunno what to do anymore so gonna have to speak with Hosting Co.