Major issues!

Firstly it worked fine, Images, Avatars etc all showing.....

I then tried adding a few new photos (tidypics Plugin), They seemed to be going fine but then, the page didnt redirect to the photos as it usually does?

So i go into my softaclous panel to see it Elgg needs upgrading to next version(You will be Upgrading to : Elgg, Version : 1.12.4) but when i hit the upgrade button i get The following errors were found :

Required PHP extension not found : mbstring

So i dont know what to do apart from back up what i have can anyone point me in right direction please??


Thank you kindly....



  • What was the previous version you were using?

  • mbstring is a php extension required by Elgg. If it's suddenly missing, something must have changed on your server, for example an update of php where the mbstring extension wasn't updated but removed instead. Re-install the mbstring extension (or ask the support of your webhoster to do it for you).

  • Sorry bout starting the other thread i didnt realize this one had a response as it didnt show, ok so this is where i am up to:

    Sorted the problem with the mBstring, But still after finally upgrading to the latest Elgg, Avatars not showing, Photos are uploading but not showing?? searched the usual and all seems to be right server directory wise!

    I am stumped!

  • I am now getting this error:

    tidypics (guid: 49) cannot start and has been deactivated. Reason: Cannot include start.php for plugin tidypics (guid: 49) at /home/teacosyb/public_html/CanalCommunity/elgg/mod/tidypics.

    but it is there ???

  • Make sure file permissions allow all files to be seen by the web server user (usually something like www-data), then reactivate.

    Also your data directory must be writable.

    So when you set your own avatar, it doesn't show?

  • OK so would this be a directory setting to change ie: The permissions to the directory itself, im a lil confused when you say file permissions to be seen by webserver... :s apologies maybe just saying in a different way i would.

  • ok so ive just resolved the issue regarding the tidypics plug-in not activating, now this is fine...

    But still the photos which have been uploaded are there but not showing, and no sir i can upload an avatar but still justs howing the Question mark, this is very strange as they were all showing up until 2 i started this says succesfully uploaded but does not dispaly??

  • I remember thinking (several years ago) that ElggFile objects created by tidypics included full paths to their location set in metadata. If this is true, then any change in path of these files (including upgrading to 1.9) will causes these paths to fail.

    I also remember fixing this bug for my project but there are so many forks of tidypics that I couldn't tell you about the one you have.

  • I've done a number of upgrades now that included tidypics, and there's no issue with the data store.  If you *move* the site or data directory then it does require the query listed on the docs or images will be broken:

  • @Toby: I also ran in to an issue like this but the problem was not in elgg rather the missing plugins in Apache make sure your server has the basic requirements to run elgg. Try to rebuild Apache.

    • MySQL 5+
    • PHP 5.5+ with the following extensions:
      • GD (for graphics processing)
      • Multibyte String support (for i18n)
      • Proper configuration and ability to send email through an MTA
    • Web server with support for URL rewriting

    Official support is provided for the following configurations:

    • Apache server
      • Apache with the rewrite module enabled
      • PHP running as an Apache module

    I am sure this will solve your problem ..