Confusion about Elgg's current release policy

It seems to me that surprisingly large amount of people still haven't understood what it means that we have adopted Semver as Elgg's new release policy.

Look at these version upgrades for Elgg core before adapting Semver:

  • 1.6 to 1.7 -> This broke plugins made for 1.6
  • 1.7 to 1.8 -> This broke plugins made for 1.7
  • 1.8 to 1.9 -> This broke plugins made for 1.8

But after adapting Semver:

  • 1.9 to 1.10 -> Plugins made for 1.9 still work!
  • 1.10 to 1.11 -> Plugins made for 1.9 still work!
  • 1.11 to 1.12 -> Yes, you guessed correctly: plugins made for 1.9 still work!

And it will be the same for the Elgg version 2. If you make a good-quality plugin for Elgg 2.0.0, it will still work without changes in all the coming releases that start with "2." (for example release 2.14.7).

So stop comparing anything that's been released before Elgg 1.9 to the current release cycle! Things have changed - and they have changed to a better direction! A direction that tries really hard to prevent the need for plugin developers to update their plugins every time we release a new Elgg version. :)

  • So do you mean like if i just upgrade from 1.9 to 1.12  i dont need to change or upgrade any of my plugins ?? then why do member self delete, RSS import, Related Item & why do all the hype plugin needs hypeapp to adapt Old & new to fix elgg compatibility. It's really confusing me these are few things that i don't want an upgrade. I don't want a broken website in 1.12 i have already removed few plugins but i am sure they will not affect much but these plugins can affect a lot for my users.

  • If you have a plugin that is fully compatible with Elgg 1.9 - yes, it will work also in Elgg 1.12.

    then why do member self delete, RSS import, Related Item & why do all the hype plugin needs hypeapp to adapt Old & new to fix elgg compatibility.

    Wow, take one plugin at a time! :) So what are you saying? Do you mean that those plugins do not have a Elgg 1.9-compatible version? Or that the 1.9-version of those plugins does not work in 1.12?

  • member self delete, RSS import

    These are both my plugins and I have not upgraded them to 1.9+ yet, but once they are upgraded they will be good for the rest of 1.x.x

  • I am sure hype plugins have 1.9 but why hype author on his recent updates have added for some plugins need hypeapp which is for compatibility fix .. if 1.9 is compatible i don't know then why he introduced this when i use hypeapp my hypecategory plugin brakes in 1.10 if i take the previous 1.9 plugin inside 1.10 hypecategory does not display the category the entity is placed but works fine in 1.9.  

    The same way hypegeo & hypemap which is in version 1.8 but works fine in 1.9 but when comes to 1.10 the width of the search bar are not aligned properly.  the same goes to member self delete & RSS plugin version is 1.8 but they work fine in 1.9 but not in 1.10

  • It sounds to me that the hype plugins simply aren't yet fully compatible with Elgg 1.9. But you'll need to ask details from Ismayil himself.

  • Versioning in hype plugins has nothing to do with core versioning. I have removed them from this community for a reason - one being to stop people from using them without thinking about the maintenance burden. I have a few dozens plugins to maintain, I do not commit to supporting any given Elgg version for an indefinite period of time. I do my best to keep my plugins working across the variety of Elgg versions, but I don't test each release across 1.8, 1.9, 1.10, 1.11, 1.12 - that is simply to much for me. My plugins are a reflection of my development style, which evolves every day. Feel free to fork the plugins and customize them to your liking, and version them the way that suits you. I can't promise that a search bar will stay intact with each release, or that I won't discover a new way of doing things that will simplify my development effort across 20 of my plugins. Obviously, I will opt to optimize things to free up to do other things.

    hypeApps has been introduced as a way to speed up my development efforts and write cleaner code that is easier maintain and eventually easier to test.

    If you have specific issues report them on github.

  • I haven't had any second thoughts on migrating client sites from 1.9 to 1.10 to 1.11 to 1.12 whenever they were released. All plugins that were compatible with 1.9 should work in any following version (there were a few minor issues, which have been addressed). I just installed hypeGeo and hypeMaps on a 1.12 site and they were working just fine.

    The only reason I can think of is class loading that was changing in between 1.9 and 1.11. hypeApps alongside automated releases using composer and grunt address that issue.

    Additionally, I am sure you have 50-100 plugins installed on your site. Blaming any specific plugin for not being compatible with 1.10 while you have over 50 reasons for it to break is unwise. Have you tested these plugins on a vanilla 1.10?

  • then why do member self delete, RSS import, Related Item & why do all the hype plugin needs hypeapp to adapt Old & new to fix elgg compatibility. 

    hypeApps uses shims to make 1.9 versions of some of my plugins work in 1.8.

  • @Ismayil Kharedinov I wish you not deleted your plugins...