HTTP 500 - Internal server error after Database Setup Screen

After installing elgg I am prompted to finish the install by filling out the Database connection info. After filling this out (with connection data that works through a sql query, dsn, etc.) I get the blank page showing the HTTP 500 - Internal sever error.


  • Yes, my system meets the spec (Apache Server, PHP 5, mySql)
  • Yes, the mod_rewrite is working
  • Yes, the php test page works
  • Yes, the database connection information is correct
  • Yes, I have tried to rename the .htaccess file
  • Yes, I have re-installed and coped three times

I am completely lost at this point. Can anyone give me any other pointers? Also, I am on a Windows server.

Please help me elgg gods!!

  • So, I am stuck in a round robin. I get the DB screen, that goes ok. Then I fill out the Settings screen, bam, 404 error. So why does it not find it, look below:


    Does that path work, no it does not. The directory is "actions" not action. So I manually type in:


    That works for a second and finally redirects to an internal error 500.

    I also get this mess in the Apache error log:

    [Fri Mar 06 10:54:01 2009] [error] [client] File does not exist: C:/Program Files/Apache Software Foundation/Apache2.2/htdocs/twg/action, referer: http://localhost:8080/twg/install.php
    [Fri Mar 06 10:54:08 2009] [error] [client] File does not exist: C:/Program Files/Apache Software Foundation/Apache2.2/htdocs/twg/actions/systemsettings/install
    [Fri Mar 06 10:54:14 2009] [error] [client] PHP Fatal error:  Call to undefined function elgg_set_viewtype() in C:\\Program Files\\Apache Software Foundation\\Apache2.2\\htdocs\\twg\\actions\\systemsettings\\install.php on line 16

    Is this the most whacked install you have seen? Is there something wrong with the current elgg download on the website?

    Please help

  • Ahh, Ben if I would have read your post earlier I would have shut my mouth and not posted something that is clearly documented :)

    I will check my settings, but swore I tested the mod_rewrite.

  • Kibbis,

    The Elgg URLs are not determined by what is on the file system.

    They are determined by mod_rewrite.

    If the URLs are not working, the problem is with your server configuration.

    You need to activate mod_rewrite and set up your .htaccess file properly.

    If you read the link Ben posted, you'll find a lot of advice for what you can check.

  • Our messages crossed.


    Good luck and please report back if you are successful (or not)!


  • Well guys, thank you for your patience!

    The mod_rewrite was turned on yesterday, but resolving my PHP / mySql issue also required a reinstallation of Apache. (good 'ol ms windows registry!!) So, when I reinstalled everything today, I did miss that step (thanks Ben!)

    I actually did get into the site. When I tried to upload a picture for my profile, another HTTP 500.


  • Failed to open stream, is this a permissions issue?

  • Have you made sure that php_gd is installed and active?

  • OK, I am in!! Now that I have a fresh working elgg system, the real work begins.

    The whole purpose of this excersize was to move my elgg system from a shared hosting platform to a dedicated. Now that I have the server working, I need to migrate. I did all of the suggested setps, but it's almost like the db is not synched. Here is what I did:

    • Create new elgg site.
    • Restore db from other site with same name
    • db admin name is same
    • updated the elgg config
    • copied data

    Now when I log in, still only the new site. Shouldn't my db have the old user info, etc?

  • I think I will start a new thread as this case has morphed. Thank you Kevin and Ben for your guidance!


  • Hi can someone please help me

    I have install elgg1.5 and I didn’t miss any files everything is install by using dreamweaver FTP

    I have tryed to open the page on the browser

    And i get this error

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

     it didn’t even give me the chance to put my database dateless