really odd behavior with elgg lately

This is really odd behavior and only started recently, but it does happen on every single elgg site I visit, whether it's here the dev site, or my own.

When I input anything, and click submit, whether it's in this forum here, updating something in the admin like activating or deactivating a plugin, really anything, nothing happens until I leave the page itself and go to another page.

It 'used to be' that I would get the green little popup box telling me the action was completed. Now I only get that popup box when I leave the current page and go to another page.

I have even tried f5 refresh while still on the same page but nothing happens. I have to leave and come back.

For example:

This post I am making, when I click save, it will not show up. So if I click any other button anywhere on this site, I will then be presented with the green box saing my post is saved. I can then return to the page and sure enough my post will be there.


I just installed a couple of plugins on my own install. I clicked 'enable' and then scrolled down and it was not yet enabled. So I clicked my profile button, and then the green box came up saing plugin was enabled. Then I return to the plugins page and sure enough it's enabled.

This is 100% reproducable for me on every single elgg site.

Using FF 3.5.2 on Vista64 ultimate.

  • hmm didn't happen when making the first post here, as it auto redirected to the group discussion page. So going to make a reply and see if it happens, when it returns to the same page... here goes

  • Yup.. exactly as expected, only this time it was worse...

    I left the page since I could not see my comment, and went to the group discussion button. I then returned to my thread, but could not see it. I then went to the wire, and used that link to return here, and sure enough my reply above was there.

    Man, this bug or whatever it is makes elgg virtually unusable for me with this browser. I can imagine users getting seriously upset thinking their actions never happen.....

    going to try now with IE 8 and see if it happens again.

    hmmm nope worked perfectly with IE 8

  • @Dhrup I don't have time as church is starting now, but I could do one of those deals where you can see my screen as I work and see exactly what I am dealing with.

    A few days ago my FF changed the way elgg looks even. Blocks are thrown all over the place as though the style sheet is totaly messed up. Nothing looks right and it does not behave right either.

    I cleared my History, closed the browser down, everything I could think of, but elgg site is still borked for me with FF.

    Anyhow, thanks for checking, must be isolated to my FF, though that makes zero sense to me...

    have a great evening


    I am having the same problem.

    Green popups appear only on refresh (along with corresponding action) or after navigating to a new page.

    Safari 4.0.2  /  OSX 10.5.8

    Works fine for me in FF 3.5.2

  • Anyone else having this issue? How do we get Ben or Pete or Marcus or Dave to chime in?

    Info repost:

    Browser: Safari 4.0.2 (works in FF 3.5.2 for me)

    OS: Mac OSX 10.5.8

    Host: Lunarpages (I have confirmed they have PHP installed as CGI. Could this be the cause? I've now gotten the same results on Lunarpages and Siteground.)