No formatting on load?

Just wondering if anyone else has run into this problem.  It seems on some themes I'm getting a flash of unformatted content.  I can't seem to work out what circumstances are required but curious if anyone else had this problem...?

  • @Daniel In my case the problem occured only when I had simple cache turned off. But as I said, Elgg 1.6.1 fixed this for me in any case.

    Are you saying that your server is running 1.6.1 and you are *still* seeing this problem?

  • @Kevin  Yes I'm running 1.6.1 on both my macbook and my server, both have simple cache off. Maybe I should enable simple cache and try again.

  • This was a problem with 1.6 when using Firefox 3.5.  If you're using Safari, you shouldn't get this error.

    Nothing was commented out in _css/css.php for 1.6.1.  What are you uncommenting?  The file that was causing the problems in 1.6 was in the profile plugin and can be see here:

  • @Brett Thanks a lot for your infomation! Apparently I did an unclean upgrade from elgg1.5->elgg1.6->elgg1.6.1, which left the profile plugin unchanged as in 1.6,  my bad :(

  • @Daniel -- It should have worked upgrading directly to 1.6.1 from 1.5.  Hrm....Fegardless, glad it's working for you now!

  • I am not sure if i am having the same problem.  I upgraded from 1.5 to 1.6.1 directly, following roughly the instructions in the UPGRADE.TXT document.  here is what I did.

    1. I made a backup of my html folder

    2. unzipped elgg 1.6.1, renamed the folder to html

    3. copied the settings.php from the backup folder to the new folder

    4. copied .htaccess from the backup folder to the new folder

    5. used my browser and point to my web site with upgrade.php at the end of the url

    6. it took sometime, then the site loaded but all the formattings are gone

    5. I went back and copied htaccess_dist to .htaccess and updated the file so that it reflects my based directory

    6. I reloaded my site, still no change.  It's now one long page of text and all the columns and panels are gone.  I have always used the default theme.

    I can log in and click on links and everything seems to work except the layout.  Have I missed something?

    Any help will be appreciated.


  • @h_ching Are you using a custom theme? Maybe you should disable your custom theme plugin first. Besides, your .htaccess will be better than htaccess_dist ( if you have changed something, i.e. RewriteBase )

    Before upgrade it's recommended to disable all custom plugins then enable them later on.

  • Hi Daniel,

    Thanks for your reply.  No, I have never used any custom themes and always used the 'default' theme.  I actually tried to use both  the old .htaccess and the new one with the Rewrite base that's applicable to me.  It didn't help.  I compared the two files with 'diff'  and notice no meaningful differences.  Formatting is my only porblem and everything else seems to work- i can log in, click on links, etc.

    I didn't disable plugins before I do the upgrade, but I guess it's a bit late to roll back the upgrade to redo it?

  • Hello,

    I went a little futher and isolated the problem.  It seems to be changes related to the 'data' directory during the upgrade process.  i have update of everything so I redid the upgrade process a few times.

    I found that if I performed the upgrade, and then put back the backup data directory, the forming reappears.  If I keep the data directory from the upgrade, the formatting is gone. 

    Is it save to keep the old data directory?