1.10.3 Fatal Error

I just upgraded to 1.10.3 from 1.10.2 and am getting a fatal error.

Fatal error: Using $this when not in object context in /home/mysite/public_html/engine/classes/Elgg/Di/ServiceProvider.php on line 116

I tried uploading the same file from 1.10.2 and get the same error.  Everything worked fine with 1.10.2.  I can not access my error logs to check there.

Any suggestions??

Thanks, Bob

  • I am having the same problem again.  When I uploaded elgg with Softaculous it uploaded 1.10.2 and when I upgraded from 1.10.2 to 1.10.3 using Sofaculous and again I get the error below.  I have checked my phpinfo and it says I am using, PHP Version 5.3.28.  Running /upgrade.php only brings me back to the same error. 

    Any suggestions??

    Parse error: syntax error, unexpected '[' in /home/mysite/public_html/engine/classes/Elgg/Di/ServiceProvider.php on line 194

  • As said before, the minimum requirement for Elgg 1.10 is PHP 5.4. You will have to upgrade it.

  • I have no idea why you're again on PHP 5.3 (you said earlier that you already upgraded to PHP 5.5). But anyway the problem is definitely caused by too old PHP version.

  • Thanks again, i am not sure how or why it dropped back.  I just did not catch it and when I upgraded back to 5.5 everything is fine.  Thanks again.