HELP: Botched domain transfer

Okay so here's the story old elgg install worked. Tried to transfer to new domain name using the instructions given be elgg docs. I backed up the data store directory the MySQL table and the mod folder, I then restored on new domain.

On new domain, I updated the engine php mysql connection information with access details. Then tried the upgrade. The process didn't work.

Can anyone help explain what I might be doing wrong?

  • What do you mean by "upgrade process didn't work"? We don't know more than you can tell us.

  • Have you updated the database entries (site url, paths) as described at

    Are the database settings in engine/settings.php correct?

    Have you made any changes in .htaccess that might need to be modified? Does .htaccess even exist?

    Is the new server correctly configured (mod_rewrite enabled, "AllowOverride All" set in Apache's config for the Elgg root directory)?

    Most likely other details could result in a failure, too. If you have checked all the reasons mentioned above and it still doesn't work, what exactly are the error messages (server log) that you get and how exactly does the "process" fail to work?

  • Okay, thank you for these tips. I will double check everything and get back to you.

    So thankful for your fast response folks!

  • I keep getting the following message:

    404 Not Found

    The server can not find the requested page:

    Please forward this error screen to's WebMaster.

  • Is your Elgg site in a subdirectory of your root folder?

  • It used to be, but now it is root.

    I transferred the site from a test server to the final domain. It was a sub-domain, now it's a root domain.

  • I tried to run the put that only took me to the error page cited above. The same thing happens when I try to login to the network.

  • I might have come in to this in the middle.. 

    Did you change the entries in MySQL DB for the new domain name;

    • Login to phpmyadmin on new instance as new username and password

    • Change the installation path

    UPDATE `elgg_datalists` SET `value` = "<the web directory>" WHERE `name` = "path";

    • Change the data directory

    UPDATE `elgg_datalists` SET `value` = "<the data directory>" WHERE `name` = "dataroot";

    • Change the site URL

    UPDATE `elgg_sites_entity` SET `url` = "https://<new domain name>/"; <- I think you are using https

    • Change the filestore data directory

    (Only change the first path here!!)

    UPDATE elgg_metastrings set string = '<data directory>' WHERE id = (SELECT value_id from elgg_metadata where name_id = (SELECT * FROM (SELECT id FROM elgg_metastrings WHERE string = 'filestore::dir_root') as ms2) LIMIT 1) ;

    • Run Upgrade Script to regenerate cache

    http://<elgg URL>/upgrade.php


  • Do you have .htaccess in your root directory? If so, add/change RewriteBase /

  • I added RewriteBase / to .htaccess

    no change

    I checked `url`  in `elgg_sites_entity` it's set to "http://mydomain"

    The other steps were also done. I try to run the upgrade.php and get the same 404 (port 443) error page.