Cron job command

I seem to be having issues with my cron job (minute) for notifications etc..

The command i have is '/usr/bin/wget --spider --output-document=/dev/null http://yappin.co.uk/cron/minute/ >/dev/null 2>&1'

But i dont seem to be getting any....

Can anyone verify that this command line is correct please?

1.9.4, Kalfakura them and River Addon

  • The command looks right to me (I'm using the same and it works fine).

    Are you defining your cronjobs in a crontab config file? Then the whole line would have to be:

    * * * * * /usr/bin/wget --spider --output-document=/dev/null http://yappin.co.uk/cron/minute/ >/dev/null 2>&1

    In case it's the server-wide crontab (on my server in /etc) you also need to add the account username of the user the cronjob command should be executed as:

    * * * * * <ACCOUNT_NAME> /usr/bin/wget --spider --output-document=/dev/null http://yappin.co.uk/cron/minute/ >/dev/null 2>&1

    You can check on the "Administer - Statistics - Croncheck" page in the admin section of your site, when the cronjobs you have defined have been running for the last time. If you use my Croncheck plugin (https://community.elgg.org/plugins/1864611) you'll also see on the same page what handlers are registered for the cron intervals. You need to have the bundled Notifications plugin enabled for sending of notifications to work.

  • Thanks for the reply. I'm usin Plesk control panel for my webhost. The times '*' are all selected as should be. And they are all ran under the admin account name /user.  I'll take a delve into your plugin and see what i come up with :)