problem installing elgg 1.9.6

Hello I have installed elgg 1.9.6 on my server

all the steps were done fine but when it redirects me to the admin page it says:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, hostmaster@server.tld and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.


if i try to go a little bit latter (when the login have expired) i can see the elgg but just like text lines, nothing else and if I write my login, last internal server error repeats

I write my server administrators and the answer me that elgg is saying this

[07-Dec-2014 11:19:37 Europe/Madrid] PHP WARNING: 2014-12-07 11:19:37 (CET): "Argument 4 passed to Elgg_PersistentLoginService::__construct() must be of the type array, null given, called in /usr/home/ on line 215 and defined" in file /usr/home/ (line 41)


  • What are your server specifications?

  • Two possible reasons I can think of currently:

    1. You've installed your site in a subdirectory of your document root path but have not adjusted the RewriteBase variable in Elgg's .htaccess file accordingly. In this case, open the .htaccess file and make this adjustment now. There's some explanation in the .htaccess file what you have RewriteBase set to.

    2. You've installed your site using an url with "www" as site url and you try to access it now without "www" or the other way round. In this case you should add the suitable rewrite rule to .htaccess as described at

  • thanks for the answer,

    1.- RJ, server guys said me that there is no problem with the specifications

    i'm going to give elgg to server guys and make them install to be sure that server specifications are ok

    2.- iionly, i'm trying it into a sudbomain which is in a subdirectory, I installed elgg (1.7 and 1.8) many times before in subdomains and it never happened to me,

    anyway I went to .htaccess


    <IfModule mod_rewrite.c>

    RewriteEngine on

    # If Elgg is in a subdirectory on your site, you might need to add a RewriteBase line
    # containing the path from your site root to elgg's root. e.g. If your site is
    # and Elgg is in, you might need
    RewriteBase /web/elgg/    - this one is the one i've changed, but nothing happened
    # here, only without the # in front.
    # If you're not running Elgg in a subdirectory on your site, but still getting lots
    # of 404 errors beyond the front page, you could instead try:
    #RewriteBase /

    i tried putting /web/elgg/ ,  /elgg/  , /root/web/

    but none makes any change

    i tried to install elgg 1.8 and i could follow further the 1st step

    any suggestion?


  • server staff have installed it and they touch nothing about code and it success at the first time, i've tryed it 5 times and I failed eveytime with the same problem i wrote before x( !!!!

    there's something about elgg I can't understand,

    what kind of whitchcraft is this!