Pluging "Ckeditor" is not showing in my plugin list

I've all files of plugin "Ckeditor" at mod folder but couldn't find it at my plugin page, please help.

  • Maybe the file/directory permissions of the content of the ckeditor plugin folder are wrong. Have you made any changes or copied the files separately to the server?

    It might help to remove the ckeditor folder and add it again to your server.

  • Hi @iionly,

    CKedior directory has the permission like other plugin (7,5,5) and I've removed & add many times but couldn't find any solution :(

  • Folder is only visible after rename the directory "ckeditor" to "CKEditor" at mod folder, but then not working properly.

    • CKEditor 1.9

      Integrates the popular rich text editor CKEditor.

      Author: Lorea developers and core developers -

        Copyright: See COPYRIGHT.txt
        License: GNU General Public License version 2
        Location: /home/feedji/public_html/mod/CKEditor/
        Type Name Expected Value Actual value Comment
        Requires Elgg version >= 1.9 1.9.5 OK
        Conflicts Plugin: tinymce Any -- OK
        Provides Plugin: CKEditor 1.9 -- OK
    • Correct name is "ckeditor". Renaming the plugin folder is likely to result in problems.

      If the plugin does not appear when the plugin folder is (correctly) named "ckeditor" it's maybe due to some faulty database entry. It's difficult/impossible for me to say what exactly might have gone wrong. I remember a similar situation I had when coding on a plugin that I renamed at one point and it was suddenly not visible anymore in the plugin list. But that has been quite some time ago and I'm not sure how I fixed it back then.

      It might help if you disable all plugin using "Deactivate all" (not deactivating each of them separately) to give the list of plugins in the database kind of a "kick". Maybe the ckeditor plugin turns up again (you should rename the plugin folder to the correct name before).

    • Hi iionly,

      Couldn't find my ckeditor plugin even after "Deactivate All" & then activate accordingly.


    • I've found the discussion thread that dealt with the problem of a vanished plugin I had myself in the past:

      But I don't know if this is of much help to you. The problem in my case was caused by using the metadata name "view" to save some settings for this plugin (which worked on Elgg <1.8 but no longer on Elgg >=1.8). I wouldn't expect the ckeditor using the metadata name "view" - surely not by default - so the problem in your case is very likely caused by something else. But I've currently no idea what it could be. Sorry.

    • I'm having this very exact issue, did anyone figure out what's wrong? Renaming the ckeditor to _ckeditor shows up in the plugin list but correcting its name makes it disappear again.

    • So this effect has been reported a number of times independently now, there's likely a systemic bug here but I haven't seen it myself.  Was there anything you did prior to it disappearing that could point me in the right direction of being able to reproduce it?

    • This happened during my upgrade process from 1.8, 1.9 and 1.10. I didn't realize it until I reached the current release.