Hi all,

I can't remember when this issue started, and can't really find much on this issue:

I am now on Elgg 1.9.4 and tried two webservices plugins, but nothing resolves this error so far.

Please provide me an indication on how to resolve this issue, i've spent a lot of time on this already.



  • Hi Pawel,

    I have no idea on what you are suggesting.
    The term "MIT" is not something that I recognize.
    I would need some instructions (if possible) to verify tha..

    Frankly, where I enjoyed Elgg before over the last few years, I have to conclude (at least for me), that this change in the Elgg code, regarding webservices, after upgrades from V1.8.6 to V1.9.x, is not working, and poorly documented. At least, that's how I experience this.

    Once again, I'm willing to persue this with you if anyway possible.


  • Assuming that you bothered to read the link I gave you, there's a clarification what MIT [license] stands for: http://en.wikipedia.org/wiki/MIT_License

    On http://www.elgg.org/download.php you can download two packages for each version of Elgg. Talking about 1.9.x. Big orange buttons lead you to packages licensed under GPLv2 that DOES INCLUDE web_services plugin that you're looking for. The small box on the right contains links to the packages that are licensed under MIT license that DON'T INCLUDE web_services plugin.

    If you didn't miss any files from 1.9.x package, the only explanation to not having web_services plugin already present in mod directory is you using MIT package.

    If you have problems with upgrading in general, make sure that you read and follow this instruction: http://learn.elgg.org/en/latest/admin/upgrading.html

  • Thanks Pawel, will check a bit later.

  • Hi Pawel,

    Thanks for your response, appreciate that.

    Here's my response on your suggestions:

    1. I don't see how your reference to MIT licenses would resolve my issue. I read the document listed below.
    2. As for the download page you provided, I installed V1.9.4 using the big Orange button earlier. I now tried the V1.9.4 with MIT license (GPL is taken off).
      That indeed did not install web_services, although there was an improvement, the external pages didn’t function, but after this installation, they did.
    3. With the above action, I had a community_web_services-master module in place, but even after removing that, no joy.
    4. I knew this link about upgrading, used it many times now, thanks anyway.

      Concluding, I still have the same error as in my initial message about web_services in this subject, although the website seems to function well.
      I would appreciate some more response before I try your suggestions on the live Elgg V1.8.6 mentioned earlier.