Issues with Admin rights not passing (Session issue?)

I'm having a problem with the Vanilla plugin. It's working fine on my test server but when I set it up on my Service Providers machine, I'm not getting the admin privileges being passed from Elgg to Vanilla. I've checked with the provider (who happens to be Arvixe) and the php Curl extension is in place. I've checked the database for Vanilla and my Admin account is set up properly (same account name as the account used in Elgg) but when I attempt to connect to the /mod/vanillaforum/vanilla forum, I get a normal user's privileges.

Also, the elgg topbar isn't showing up on the vanilla forum and the only way I can get back to the Elgg site is to back up to the previous page in the history.

I've installed it as per the instructions. Any suggestions as to how to fix it???

  • Hi NeilR,

    If it works fine on your test server but not on another one, it sounds like that either:

    a. you installed it differently on the two machines, or

    b. you have some problem with your server configuration (not the plugin) on the second machine.

    I'd suggest deleting the plugin directory and dropping the tables on your Vanilla install and installing from scratch following the instructions in the README.txt very carefully.

    If that doesn't work, it would appear to be a server configuration issue and your best bet would be to check your php error log for hints, and ask your provider for help.

  • Ah, one other thing.

    The plugin does not pass the "admin privileges" from Elgg to Vanilla. The first Vanilla account created is the admin. If you need to make other Vanilla accounts admins, then search for the instructions on this site as I've already posted them on another thread.

  • @Kevin,

    I've tried a ton of things as well as uninstalled/reinstalled and I can't get it working. The error log gives the following message (multiple times):

    PHP Warning:  


    [<a href='function.include-once'>function.include-once</a

     >]: failed to open stream: No such file or directory in 

    /home/nrerup/public_html/mod/vanillaforum/vanilla/appg/settings.php on 

    line 254

    - I've reviewed the Server and it's the same configuration as for other instances of Elgg

    - I've ensured that the conf directory has permissions set at 777

    - I've done a complete reinstall of the elgg instance

    - I've had the Service Provider do an install of Elgg (they have that available for a number of their clients)

    - I've made sure the .htaccess file is configured for the rewrite with ReWriteBase / put into the file


    I'm at a loss now. Any suggestions would be appreciated ...



  • Hi NeilR,

    I can't debug Vanilla forum for you.

    Having said that, there is an obvious problem from what you have posted.

    Do you see line 233 in vanilla/appg/settings.php ?

    It is:

    include(dirname(__FILE__) . '/../conf/settings.php');

    That sets LIBRARY_PATH to something reasonable (not /path/to/your/library/) and DATABASE_VERSION to 2 (so there is no way the code you mention on 254 should even run).

    If the vanilla/conf/settings.php is not there with the settings I mentioned, something has gone very wrong with your Vanilla install.

  • Hey Kevin,

    Just thought I'd let you know that, although I don't know what the issue was, I fixed the situation. I was trying to use the shared server provided by Arvixe but wasn't able to get your mod working. After what must have been 8 hours working on it, I decided to try a different provider's server. So I set up an account at A2Hosting and it worked the first time for the install. The main difference that I could find was that the Arvixe server is using Sabayon linux where as A2 is using CentOS. So, without having access to the actual server configurations, either Arvixe has done something to their server configuration or there is a bug in Sabayon that has issues with the your mod. In either case, changing Provider servers has the mod working now.

    Thanks for your input ...