Can’t connect to database


I’m trying to install Elgg on my server. I think I have done every okay.  I downloaded the 1.2 version. I create de database and the data file with chmod 777. I direct my browser to the correct URL and Elgg shows me a welcome message inviting to enter the information of my database. I did that. The problem is that it keeps telling me that it can’t connect to the database because of this message:

Elgg couldn't connect to the database using the given credentials checho9@ (pw: ****).

But everything is correct. At list I think so…Any way I can’t change them anaymore.  I try to fine the engine/settings.example.php but it’s not on the files I have download. So, how can I fix this…?

The url of my legg  site is:

Thank you very much

Miguel Damiani

  • Everything is working fine now. I really had two little problems which I solved after 3 installations….

    First one: I was looking for the example.php on settings instead of engine. I changed the name of this file like instructions says, and update with the correct information and all went fine. I made a mistake in the path of my elgg site, and that is why a had to install two times more. Now everything is working…you can see it at:

    Well it’s true that I don’t have nothing install yet. I have to read the tutorials to install all the pluggins so my site will be unique and attractive…at list that is what I hope.

    Thank you very much…I´ll be coming back on the near future.



  • antifmradio I'm having the same problem. I'm also installing v1.5 on a subdomain and it can't connect to the database to even install the tables. My db stays empty. All of my db settings are correct, checked many times in the engine/settings.php file. I can't think what else to do!

  • I am having the same problem. :(

  • About path

    If you are using Cpanel, the path name will look like /home/name/public_html/folder/

    name is your Cpanel user name and folder is your Elgg folder, of course. You can fix this at Admin > Site Administration.