Edit Profile blank page


I'm new in this big community, I see that elgg is really good to do a community page, and at this moment I'm only having a small problem. I have some plugins installed, but I desactivated all to see if it's an error of a plugin and don't seems to be caused for any plugin, so I want to ask if I'm the only one having this problem.

When an user or admin click the Edit Profile button, it appears /profile/user/edit but it appears a blank page. How I said I tested to desactivate the installed plugins and nothing changes. I wanted to know if it's caused for a plugin (and now if I desactivate it, it don't get solved) or if can be for a bug i the general elgg installation.


What do you recommend? Should I reinstall all the site, install a plugin to change the edit profile page or what?

Thank you very much, I hope I will can solve it, and sorry for my bad english :P


  • The error can be due to any thirdparty plugins. Make sure you have disabled all the non bundled plugins.

    You may also try this http://docs.elgg.org/wiki/White_page . It will make the errors visible if there is any.

  • @Team Webgalli I will test some things from the Wiki, thank you! 

    I'm sure that I had disabled the non bundled plugins, i was testing disabling each one and later all toghether and nothing happened! But in the site that you posted there's some things that I can try, I will post the results, thank you very much!!

  • Have you added any language files, i.e. any additional languages apart the English language files that are bundled with Elgg core, or have you modified any language files? If yes, it's possible that any of these additional/modified language files is saved with wrong encoding resulting in issues. If you have added or modified any language files save them with encoding "UTF-8 without BOM". This would correct at least the encoding. But no promise that this is connected with your issue.

  • @iionly we added another language and edited the original, but I see that all of them are well encoded! don't seems to be that problem. I will try anyway to put the original languages files to see if it gets solved, thank you anyway!

    The page is still creating, so I'm thinking to reinstall it to try to solve the problem. I activated the PHP error log but still giving the white page, is strange.


  • Finally I reinstalled the site and now is all working, thanks to @iionly and @Team Webgalli anyway for the help!!