Problem with installation

Hello, and I'm sorry if this is the wrong place to ask - I've looked through the troubleshooting wiki and couldn't find anything that applies.

I'm having a problemwith installing elgg 1.5.

My server is a shared host using Linux, MySQL 5, and PHP 5.2.10.

Here's the problem: I have the database details entered.  When elgg asks for site details (site name, url, folders, etc.) and I click submit, I get a 404 error.  I suspect this is because the url that the submit button points at is written "/action/systemsettings/install" instead of "/action/systemsettings/install.php", but I can't determine which included file generates that button so I can't test out my thorey.

I would greatly appreciate any help anyone has to offer.  Thanks!

  • Have you followed all the steps mentioned at ?

    I did my installation by consulting it.

  • Yes, thank you.  I'm trying to enter the site details from /install.php, and as I wrote above, the form is not submitting correctly.  I can't find anything regarding this problem in the wiki.

  • have a look at your tables in mysql Phpmyadmin

    Site entity should point to your elgg site domain installation

    I think it is elgg data config table should point to your correct paths line 6 & 7 or around  there (document path  route, and your data folder path) check these and make sure they are correct this is probably where your problem is


  • I see elggconfig and elggdatalists (both of which hold no records) but no elgg data config.

    tables in my elgg db:

    (0 Rows)  elggaccess_collections
    (0 Rows)  elggaccess_collection_membership
    (0 Rows)  elggannotations
    (0 Rows)  elggapi_users
    (0 Rows)  elggconfig
    (1 Rows)  elggdatalists
    (0 Rows)  elggentities
    (0 Rows)  elggentity_relationships
    (0 Rows)  elggentity_subtypes
    (0 Rows)  elgggeocode_cache
    (0 Rows)  elgggroups_entity
    (0 Rows)  elgghmac_cache
    (0 Rows)  elggmetadata
    (0 Rows)  elggmetastrings
    (0 Rows)  elggobjects_entity
    (0 Rows)  elggprivate_settings
    (0 Rows)  elggriver
    (0 Rows)  elggsites_entity
    (0 Rows)  elggsystem_log
    (0 Rows)  elggusers_apisessions
    (0 Rows)  elggusers_entity
    (13 Rows)  elggusers_sessions

  • Elgg v1.5 install is usually 1 5 - 10 minute task

    Why not just

    (1) kill the install

    (2) empty the databse and

    (3) re-install ?

    That will take much less time and effort...

    ( I do this all the time when I break my test elgg site ).


    Watch for parms for your MySql database and site URL, home path, data path !


    If still problems.. you might be missing some prequisites.. then post the exact steps of your reinstall., to make it easier to answer your questions.

  • well, I was hoping there was a simpler solution than reinstalling and hoping the same thing didn't happen again.  At this point, there isn't anything to lose, but I tend to think of a re-boot as a "last option."  I'll go ahead and try it, though.  Thanks!

  • i think i ran into the same problem once when i installed. make sure you have the .htaccess file setup correctly.. (ie, copy the default htaccess into your .htaccess)

  • I ran into this problem before... hence, the stitch marks on my wrists!!!

    I'm afraid whatever solution you apply, it aint gonna be a very simple one.

  • well, I tried just removing engine/settings.php and emptying the db, but I ran into the same problems.  I am now deleting *everything* and emptying the db again, after which I will start over from scratch.  I'll let you know how it goes.  Thanks, everyone.