Blank page logged in as admin

Well, I have a serious problem:

I was using a shared server (in arvixe), then I made a transfer to a dedicated server(in arvixe).All with help of the Arvixe transfer team.
After the transfer my site was working well, for all of the users, but not for my adm account.
Everytime I try to login with my adm account, I only see a blank page, no matter what page it is, this is the result.
Arvixe transfer team asked me to disable all of the plugins in my shared server, then I did it...they re-transfered my site, to the dedicated, with all the plugins disabled and the result is the same!

Everytime, in any page, if i am logged in in my adm account, I only see a blank page...Help me, please.

  • To disable one by one, I just renamed the folders of the plugins one by one, starting from my theme.
    Well, this is not good: As I said, The dedicated server is a copy of my shared.

    In my shared server (I have acess to my admin account), I created a file named 'disabled' and all the plugins were disabled.And I still had acess to my admin account.

    In my dedicated, I created a file named 'disabled' and all the plugins were disabled.But here, I still didnt have acess to my admin account.

    I made a backup of my dedicated server and used in my localhost.Damn, with all the same plugins, enabled or disabled, in my localhost my admin account works...I really don't know what to do.

  • There could be a problem with permissions of the data directory. Maybe only the caching directories within the data directory are affected. You could delete the system_cache and views_simplecache directories in the data directory. They will then get recreated when the cache is rebuilt.

  • Just did it, iionly.
    I deleted both (system_cache and views_simplecache), and still see a blank page.If I remove admin from this acount I can see everything.But when I name another user as admin in the 'users_entity' table, the result is still the same.No matter what account, if it is an admin, then will return a blank page.Thanks for the help and your time, anyway.My permissions in data directory are 755.

    Any ideas? Please, I can not make a site without an admin =/

  • Have you tested in localhost with a backup (including a backup of the database) as it currently is on your dedicated server? Or have you tested with a backup that was taken from the shared server before moving to the dedicated server?

    In the first case it might be that some files within your Elgg install directory have some wrong permissions or are invalid/missing. This might only cause issues when logging in as admin. It could help to fix the permissions or to copy the backup taken from the shared server again on the dedicated server.

    In the latter case with the backup tested on localhost being different from the version on your dedicated server it could also be some database entry causing the trouble that was newly created on the dedicated server and only shows up when logging in as admin (or as the very user who created this content). If you log in as admin can you access the admin area (or other pages of your site different from the page you would be redirected after login) if you enter the corresponding page url directly?

  • I am sorry the lack of details, iionly.

    What I really done was copy the 'mod' directory from my actual dedicated, then I tested the plugins in a fresh install of elgg.So, I concluded that the error was not in any of my plugins.The database from the dedicated was not involved in it.

    My actual dedicated was already transfered 3x, all the transfers come with this error, and my shared is still working.

    I am assuming that some file(s) came corrupted, but how can I discover wich file(s)?Or can be some database entry, but I am still not able to discover what it is on my own.This file(s) just affect my admin account...


  • What happens when you have just a fresh install? If it works next copy over your mod folder, set the priority and activate. If its still working, copy over your data folder. And if all goes well you only have the databae left to blame. Backup the current and copy the old one over. If its broken try to copy and replace the tables one by one. You should be left with your bad table and someone will kmow what to do. If you follow these steps you should be able to pinpoint the issue, OR it will just magically work :)

  • what was your old elgg version and the new elgg version?

    also if you try my advice, keep checking your error log for when those errors start to occur *what plugin you just enabled* Then you can take care of them all afterwards.

  • From everything that's been mentioned it seems very likely that the issue is database related.  There is something there being loaded that has admin-only permissions that is causing a loop (or has an extreme amount of metadata) eating up your memory.
    Back up the database, mount it in localhost and check again.  On localhost you can be free to insert breakpoints in the code to see what's being loaded at various points in the page generation and see what the issue really is.

  • As Matt said, a database issue can be responsible for the error. If you only tested your mod directory on localhost also a damaged core file can causing the issue. If a damaged core file is causing the issue you should be able to fix the issue by overwriting your Elgg install folder with the orginal files from the Elgg zip archive (this will not affect 3rd party plugins in the mod directory and if you haven't modified any Elgg core files it won't be a problem either).

    The reason I asked if you can access other pages like the admin section of your site if you enter the urls directly is that it might help to use the Database validator plugin to check your databse for invalid entries. You might get the white page as admin if you log normally because a faulty entry would be displayed on the page you normally land after login. But if you can access the admin section there is some chance that this faulty entry is not loaded. If this works you should try to use the Database Validator plugin and make a validation run on your database. If any faulty entries are found, let them get repaired.

  • Well, I do not have acess to any page when I am logged in as admin, I already tried many times to enter directly the administration urls (/admin, /admin/plugins...)  so I think there is no way to enable a plugin to test.

    To see if the problem is in my datbase, I will have to get my actual database of the dedicated and transfer it to my localhost, right?How can I do this?Step by step please, I am not so familiar with databases