Image exceeds the size limit 1024


When I try to upload images using flash uploader or basic uploader I get the error "image exceeds the size limit 1024"

I have provided 7 MB as the maximum size of the image to upload it. But I am getting this error even if I am uploading images of 2 or 2.5 MB.

Please help me in resolving this issue

  • Ajay,

    As iionly mentioned. Its pointless to change any of the values in htaccess if its not the method you webserver is using for the config. You need to find out which method/file is being used to set the variables.



  • Hi iionly,

    As per your suggestion/post "The image filesize limit on the Tidypics settings page is meant to limit the image size to lower values than set for example in .htaccess or php.ini. This way you could upload for example videos or any other larger files using the files plugin or other plugins but still limit the size of images to be uploaded using Tidypics to smaller sizes."

    How will I be able to inform each and every user to upload pictures of smaller size. If I enter 1MB in settings of tidy pics it shows upload pictures lesser than 1 MB but even after that I get the error and am getting emails from users with the same error. 

    Please let me know how & what should I can change in the php.ini and the path to this file as I will not be able to get the support from my webserver (shared) from godaddy.

  • I can't give much support on goddady server administration, but maybe this posting will help: Please be careful: I don't know if godaddy allows changing these values using your own custom php.ini. And I don't know if it will work with only a single php.ini in your Elgg root directory. Normally, the php.ini is a server-wide config file.

    But before you try adding a custom php.ini let's sort this out once again:

    • are the values above from your .htaccess or have you mistakenly looked into htaccess_dist? In htaccess_dist the default values are listed while in .htaccess access are the values set that are actually used (if the same default values are set in .htaccess that are different from what shows up on the Tidypics server info tab it really is true that they are ignored).
    • the server info tab of Tidypics shows the php values that are the definitely in use on the server. If upload_max_filesize is 32MB and post_max_size is 33MB this would be on the lower range of what is useful but it should at least work for 1 MB images (and even for slightly larger images).
    • the origin of the "image exceeds the size limit 1024" error message is the Flash uploader of Tidypics. Try the basic uploader to verify if the same error message occurs, too. If not, stick to the basic uploader.
    • what have you entered on the Tidypics settings page as maximum image size exactly. You would need to enter only the number and not more, i.e. for a 1MB limit it's only the number "1" and not "1MB".

    The upload page informs your users about the image size limit set on the Tidypics settings page. If uploading smaller images than that fails to work, the problem is due to a limit set lower elsewhere. You've got to figure out what is limitating the size and if necessary increase the limit. If the problem is within the .htaccess file (or due to limitations set in php.ini and anything in .htaccess ignored) is something you need to figure out. And even if you are on a shared server on godaddy they should at least tell you what the limits are even if they don't increase the limits.

    As I said, the error is from the Flash uploader, so I would suggest to test the basic uploader to see if there's a difference. You might also want to verify if any other plugin installed on your site is causing the problem (or at least disturbing the flash uploader).

  • Hi,

    The above mentioned values are from .htaccess file.

    I have tried using the basic uploader to verify if the same error message occurs. I got the error "The page is not available" and in the address bar this is the code "Yoursite/actions/photos/image/upload"

    I have entered in the settings page as "1" or "5". I have entered only the number

    I have checked the php.ini5 file in my server (shared) after discussing with godaddy support. This is the code that is available there. I have got this code from  php.ini5 from the webroot.

    cgi.fix_pathinfo = 1
    date.timezone = America/Phoenix

    After speaking to a support person in godaddy I have changed the code in php5.ini file to 

    cgi.fix_pathinfo = 1
    date.timezone = America/Phoenix
    # upload_max_filesize is the maximum size of a single uploaded file (5 MB)
    php_value upload_max_filesize 5242880

    and saw that was able to upload some images in my website using basic uploaded. But when I tried to upload images of around 4 MB (10 images) using basic uploader, I again got the error as mentioned above "the page is not available".

    I used the flash uploader again and am getting the same error "1024" as mentioned above even when I try to upload a single image of around 1.2 MB

  • With addition to the above,

    I tried to upload images of around 2 MB using basic uploader and was able to upload them. Again I tried to upload just 1 image with 4 MB and got the error 

    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 13760 bytes) in/home/content/33/11326133/html/mysitefolder/mod/tidypics/classes/TidypicsImage.php on line 210

  • There are several different issues here:

    • within the php.ini5 file you should also define the post_max_size limit, if it fails to work via the .htaccess file. So, add for example the line "php_value post_max_size 32M"
    • The "allowed memory size exhausted" error is due to the php variable memory_limit being set to 64 MB. When using the GD php extension A LOT memory is required for image resizing (= creation of thumbnails). So, either increase memory_limit (again via your php.ini5 file) or use another image library (ImageMagick) if possible that has lower memory requirements.
    • I also can't guarantee that any other 3rd party plugin installed on your site might be responsible for the "The page is not available" error. If this error turns up on an image page after a successful image upload then I would certainly blame another plugin. If the error already turns up already when trying to load the upload form (or for the 1024 error using the Flash uploader when all necessary php variables are configured correctly), it might also be due to a conflict with another plugin.

    For a start, make sure that memory_limit, post_max_size and upload_max_filesize are set to reasonable sizes in php.ini5. Do these values show up then on the server info page of Tidypics? If not, the upload will most likely fail, too. If yes, try uploading images using the basic uploader. If there are any problems, try to disable other 3rd party plugins temporarily to figure out if any of them conflicts with Tidypics.

  • Hi,

    As per your suggestion, have set the "memory_limit, post_max_size and upload_max_filesize" to reasonable sizes as mentioned below in php.ini5 file

    # limit the maximum memory consumed by the php script to 164 MB
    php_value memory_limit 164M
    # register_globals is deprecated as of PHP 5.3.0 - disable it for security reasons.
    php_value register_globals 0
    # post_max_size is the maximum size of ALL the data that is POST'ed to php at a time (50 MB)
    php_value post_max_size 58388608
    # upload_max_filesize is the maximum size of a single uploaded file (5 MB)
    php_value upload_max_filesize 5242880
    # on development servers, set to 1 to display errors. Set to 0 on production servers.
    php_value display_errors 1

    But these values are not getting shown in the server info pages

    Also is there any option where I can ask users to upload images to google picasa or any other 3rd party website and to enter the url of the image in my website to upload the photos?

    I think that this will become much easier and better and will solve the problem. If this can be done, then I'll be in need of a form where users should be able to add atleast 10 urls at a time and I should be able disable basic uploader and flash uploader.


    Is there any plugin which I can use instead of "Tidypics" :-(

    Please help...

  • As I mentioned in an earlier post already, I was doubtful that adding a single php.ini file in the root directory will work. For a start: did godaddy say you should name it "php.ini5"? What about naming it "php.ini"? Still this might not work then. The php.ini is normally a server-wide config file. If you use a custom php.ini instead you might need to add this file within EACH directory these settings should be used (which is quite impractible as you would need to add it to quite a lot of directories within the Elgg installation).

    If it fails to work to get the limits set properly (or change them at all), this is a problem caused by the limitations of your hosting plan. There's not much that can be done to avoid these limitations then apart from changing your hosting plan.

    There's currently no way to embed images from other sites instead of uploading them to your site using the Tidypics plugin. I also don't know any existing plugin that would allow you to embed a reasonable number of images from other sites. The Tinymce editor allows to embed images from other sites in postings by providing the urls of the images. But this surely is not a good option to add a large number of images or building up an image section on your site.

  • Hi,

    When I logged in to my server, I saw that php.ini and php5.ini files are already existing.

    Shall I share the code of php.ini file?

    I really need to enable this or correct this since I am creating a website for adventure activities and sharing of photos is a must and only then users will be more happier and will visit the website...


  • Please read and also follow the links to and

    For a start in php.ini or php5.ini (so php.ini5 might already be the wrong file name) the format of setting a php variable is not

    php_value memory_limit 164M

    as within htaccess but

    memory_limit = 164M

    If in doubt I would advice you to ask godaddy support to help you creating a suitable php.ini (or php5.ini).