Tidypics & Website visitors

Site visitor (not logged in) going into Tidypics viewing an image (public) within an album (public) clicking on the name of the owner (link) results in error HTTP 500. This works ok when clicking the owner of an album.


  • I was not comprehensive enough with this one.

    It is the same behaviour I mentioned earlier with regular user and MyBlogs / MyPhotos. The admin is able to upload images and also able to click the owner link of images without issues but both a guest and a regular logged in user are unable to click the image owner link, they get a HTTP 500 error.

  • Which version of Tidypics are you using? Is it the official 1.8.0rc1? This version has some issues that might result in problems in the latest Elgg 1.8 releases. Try http://community.elgg.org/plugins/1194049/1.8.1beta10/elgg-18-tidypics instead.

    Though I think the problem might not be related to Tidypics if you have the same problem also with blogs - see your other thread.

  • Yes iionly, that is the version I have installed at the moment (1.8.0rc1)

    I agree, also looking at the Groups that I stumbled upon it is pretty consequent behaviour but weird but I will give the next beta version a try to be sure. Sometimes there's more that meets the eye...

    Thanks again!

  • OK, even though I would not have guessed it seeing everything work well being a logged in admin but I just selected all non-bundled plugins in Elgg and deactivated them. Sure enough my regular logged in user is having no more issues with the blogs and groups..! Weird how one or more plugins can cause these http 500 errors making you think there is a rights issue on the folders in the first place.... sigh :)

    iinoly and Rodolfo, (and others) I will try to figure out what plugin(s) is/are causing the issues I mentioned. Might be an idea to add an option for the plugins in the download section where people can 'vote' for quality or something making it a better guess what plugins should be of a good quality and what might be a bit risky or less stable for downloading....

    Thanks for thinking along guys, keep you posted!


    Lee's Block User for Elgg 1.8.16 (block version 1.0.6) is breaking my regular logged in users when viewing myblogs / friends blogs / my groups etc...

    Now, the tidypics will not let my logged in users upload images but admins can.... I will try the newer version now to see what gives....

  • Ok, glad you found the problem.

    Rodolfo Hernandez

    Arvixe/Elgg Community Liaison

  • The problem with the http 500 for regular logged in users went away for blogs and groups so that is in the clear.

    I have now tested Tidypics 1.8.1b10 and I saw some changes but no improvement really. For starters the css, when uploading the 'step 1 text' looks 'weird' (doubled?). I noticed step 3 is now automated which is a plus. Unfortunately I still have the upload issue with regular loggedin users.

    For admins everything works fine but the regular logged in user can start the upload process, it also looks like there is actually something being uploaded but then after the upload when the details can be entered the image is missing. I do not get any errors during the process just no image.

    Also I found that the regular loggedin user is unable to upload 'files' using the files plugin.

    However, since my admin is having no issues I still think it is plugin related and I do not want to set the rights to 0777 on the data folder. I did disable all extra plugins to see if that would make any difference but it didn't. I also tested the upload for files with tidypics disabled but same result upload process looks fine but no image showing as if either upload is missing or another reason.

    Anybodyelse having this issue or maybe some ideas where to look for the solution?

    Thanks in advance,


  • In addition, also tried to upload an avatar being logged in as regular user and the same issue, no errors and no image... :(

    I did notice others having a similar issue with avatars but it is not said whether it is with admins, regular users or both. Again, as an admin I do not have issues uploading but logged in users seem to be cripled.

    Very frustrating, help?

  • Ok, now after doing some research on my filesystem I noticed there was a folder created with 0700 rights and apache as owner instead my account. After I took ownership and changed the folder rights to 0755 everything works!

    The folder created is: /data/2013/08/27 with user rights 0700 which is not working. Another thing I notice here, today it is the 30th and I wonder why the folder is the 27th.

    Hope this helps figuring out where to look  for solution?


  • Further what is making me frown my eyebrows, I took another look after I uploaded an avatar and now there's another folder created (/data/2013/08/27/309/profile) with 0700 rights. The funny thing is that when deleting my avatar and re-uploading another image it works as well making me think that it is not so much the 0700 but somewhere along the folder creation the apache ownership together with the 0700 or just the apache ownership is messing things up...... correct?