Https works fine but homepage graphics are gone

Hi everyone,

As in the title of this discussion, I purchased static IP+SSL certificate which are correctly pointing to my website but:

  1. the user has to manually type https://... to login from that page (just a redirect I should setup somewhere or does Elgg fails to automatically load the https homepage after enabling the 'login via https' feature?
  2. the login works properly but there's no graphics on the https homepage, should I edit something (what?) or is it some failure of the https feature within Elgg?

Any help very much appreciated,

Cheers!

  • 1. Edit your .htaccess to redirect everything to https.

    RewriteCond %{HTTP_HOST} !^sitename\.nl
    RewriteRule (.*) https://sitename/$1 [R=301,L]
    RewriteCond %{SERVER_PORT} 80
    RewriteRule ^(.*)$ https://sitename/$1 [R,L]

     

    2. Dit you configer Elgg to use https?

  • Thank you @kooistragfakkel

    2. Yes I enabled the 'use https login' feature in elgg and it works but what you suggest in point 1. scares me because I am not sure if the whole site would run properly under https (isn't elgg enabling the https login only?) and, also, what about the homepage design? Would it work fine if now it is not even if only login via https is enabled?

    Cheers and thank you again!

  • @Michelle

    Well, did you get the SSL certificate before or after installing elgg? Anyways, it should work properly. In Cpanel, you can add a wild card to redirect from http to https

    Rodolfo Hernandez

    Arvixe/Elgg Community Liaison

  • @rjcalifornia First of all thanks :)

    I purchased the ip+ssl after intalling Elgg and as mentioned above login works via https but not the whole site and when logging in via https the homepage design is completely gone, only text is there.

    I tried to add a wildcard from http to https for the whole site (both with and without 'www.') redirect via cpanel and the error I receive is:

    The webpage generated a redirect loop

    Any clue?

  • sounds like the redirect was done incorrectly - is there any reason to only have the login as https?  Change the entire site to https - this also means changing the site url in the admin settings

  • Our intranet is running in full https mode (after we switched from http to https).

    The tree staps what i dit:

    • Changed the website url on the admin settings to https://sitename
    • Changed the .httacces file to redirect everything to https://sitename (include https://www.sitename).
    • Searched and replace old http directions to https inside the database (this because our employees had used it without https)
    • Run upgrade.php
  • Guys, thank you so much, really appreciate it!

    First problem solved, the whole site is now under https with its beautiful theme :)

    The fact that in admin area I also had to change the 'Site URL' to https was not clear to me and even if I thought it...I was scared to mess up the entire site. Well, I hope my stupidity helps others checking this thread in the future :)

    The second issue, homepage redirect from http to https by the way is still there. Cpanel redirect seems not to work properly (I tried all combinartions with/without www. and final '/' and with/without 'wildcard' redirect... don't really feel to edit the .htaccess ... that will be my last option @kooistragfakkel Hope cpanel will help me in some way :)

    Cheers and thank you all so much again!

     

  • Hello,

    Again thank you to the mates above and...for future dummies like me, at least for my webhost I had to do the following to enable all elgg site to work properly on https protocol:

    0- Checked for both dedicated IP and SSL certificate in my domain (purchased the first one, already in my VPS package the second)

    1- Changed 'Site URL' to https://MYSITE/ in admin's 'Settings'->'Advanced settings'

    2- Enabled 'Enable HTTPS logins' in admin's 'Settings'->'Advanced settings'

    3- in .htaccess file added at the top:

    RewriteEngine On
    RewriteCond %{SERVER_PORT} 80
    RewriteRule ^(.*)$ https://www.MYSITE/$1 [R,L]

    Cheers!

  • Thanks for posting the solution

  • Dummy's only chance to be useful...

    Up with sharing solutions, up with Elgg! :)