Photos not showing in album

I'm using 1.8.16 and just uploaded the most recent Tidypics (Arvixe, permissions 755)...followed the instructions and did the update.  I could upload 5 photos at once to my new album but all the photos only display a red X and that's also what shows in the activity and on my profile page (the previous tidypics version I had did the same thing).  The avatar upload works fine, also the files.  I'm sure this is a simple thing I'm overlooking but have been unable to find anything in the topics.  Help please? 

  • and bad news.... it is working only on albums already created. It is not capable creating a new folder image and a sub folder with the album id.... and is not related to libraries (it is not working with any of the libraries).

    I tested if file plugin creates a folder under the user id (e.g. in the above photo, my id is 33 and file plugin created file folder) and is working, so I wouldn't say it is a problem of access to the folders.... 

    Where are the lines that create a new folder under elgg_data when a new album is created? Is that folder created when the album is created or when a new photo is uploaded only? How can I debug it (check if the folder is created when required?)

    Thank you.

  • One more thing, I deactivated ALL plugins (except tidypics) and still not working

  • One more thing, I deactivated ALL plugins (except tidypics) and still not working

  • confirmed failure: I manually created the folder associated to the new album I've just created (in my case flder 976 under image under user 33 under day 12 under month 11 under year 2013 under elgg_data) and guess what, I uploaded a photo in this album and it worked, meaning the photo uplaoded and is displayed correctly.


    Outcome: on my sistem (hosted by godaddy) the plugin fails to create the folder when a new album is created. How could I fix this? Where are the code lines located?


    Thank you.

  • Then you are not using the latest version of Tidypics or you have not updated cleanly to the latest version. The problem with creating the album folder within the data directory is exactly the reason why Tidypics rc1 does NOT work anymore on Elgg 1.8.15 and 1.8.16.

    Use instead. On upgrading disable Tidypics on your site, delete the tidypics folder in mod completely. Then copy the new version on the server and enable it again. Should it still not work then and the folder fails to be created the permissions and/or owner and/or group of your data directory are set wrong.

  • That was a FAST and GOOD answer. Thank you so much.