Photos not showing in album

I'm using 1.8.16 and just uploaded the most recent Tidypics (Arvixe, permissions 755)...followed the instructions and did the update.  I could upload 5 photos at once to my new album but all the photos only display a red X and that's also what shows in the activity and on my profile page (the previous tidypics version I had did the same thing).  The avatar upload works fine, also the files.  I'm sure this is a simple thing I'm overlooking but have been unable to find anything in the topics.  Help please? 

  • With "most recent" Tidypics you mean which version exactly?

    The "latest version" from will fail to work in Elgg 1.8.15 onwards. You won't be able to upload images to new albums (existing albums should still work), because creation of the album folder in the data directory will fail.

    You can either download Tidypics from or use my fork from

  • By 'most recent' I meant Elgg_1.8_tidypics_v1.8.1beta9.  (I was testing using tidypics_180rc1 when I first had the problem so I removed that folder and tried the 'beta9' with the same result.)

    Is there a necessary place in the plugin list for it to be?

    Any help would be appreciated.   

  • Postion of the plugin in the plugin list shouldn't matter much but the more it is towards the bottom the better as it will have a higher priority then and it's less likely that other plugins interfere.

    When you updated Tidypics did you remove the old Tidypics plugin folder before installing the new version. If not, please remove the folder and re-install.

    Have you checked the Tidypics plugin settings page if there is an "Update" button shown? If yes, excecute the update.

    Are you using the Flash uploader or the basic uploader? If you currently use the flash uploader try the basic uploader to see if it's an issue of the uploader.

    Can you try uploading an image that fails to show into an existing album? Does it work then?

    Is there really a red X image shown or an image showing a question mark? Is it only for new uploads or also for existing images that showed correctly before? I wonder if this might be a browser issue (at least partly) because Tidypics should show a placeholder image with a question mark if it fails to load the corresponding image. Which browser do you use? Can you test with another one?

  • I was using IE 8.

    When I updated I did remove the folder first and I clicked the 'update' when activating the new one, flushed the caches, and such.

    Yes...I uploaded 5 photos with the flash uploader and all gave me the red X (not the ?).  I had no prior albums to all new installation.

    Since my last post I moved tidypics down my list to where the 'files' were (only because the files would take a photo fine), then tried the basic uploader with one photo.  That worked.  So I tried 4 more and they worked also. 

    Next I logged in with Chrome and the flash uploader now worked fine.  Logged in again with IE8 and the flash uploader worked fine with it too! 

    Thanks @iionly for your fast help.  Must have been the position in the mod list (I tried the top and bottom before I even posted here...neither worked).  All working good now!  

  • Actually, I'm having exactly the same issues with my fresh install of Elgg 1.8.16 with tidyPics 1.8.0-rc1. The images are uploaded, but no thumbs are shown. Actually the img src is mysite/photos/thumbnail/46/small/ , so no img is stated here. I tried Clyde's solution but no luck. Can this be a caching or writing permission issue maybe?

    Regards, Jeroen

  • @Jeroen: it will not work with tidyPics 1.8.0-rc1 on Elgg 1.8.15 or 1.8.16. Clyde's solution won't work either with this version. You need to use either the latest development release from github or the latest version of my Tidypics fork. I've linked the download pages for both versions above. Only with any of these versions installed uploading images to new albums will work at all. Only if it fails to work even then you can try Clyde's solution.

    [As a sidenote: Flash uploader in my fork is broken in beta9 - just noticed this today and still trying to find the bug. But the basic uploader should work.]

  • similar issue. There is no photo loaded in elgg data folder (a new folder is created for a new album) and only album thumbs are create whe I load a photo (largethumb, small thumb and thumb). The GL should be working as I have avatars. Tryied .9 and .11 on elgg 1.8.16. Please help. 

  • Difficult to follow what's going on here. So, the thumbnails are created and saved (are they also displayed on site?) but the original image is neither saved nor displayed? The only thing that comes to my mind right now is to increase the size of post_max_size in Elgg's .htaccess to some larger size. Though I'm not sure this will really help as I've never obsevered such a behaviour before.

    Try also what happens when you temporarily disable all other 3rd party plugins. Maybe one of them results in a conflict. Maybe also try uploading a single small image for testing. If the upload works for a small image but fails for larger images it's quite likely an issue with memory_limit and/or post_max_size.

  • Good news, either bad word filter or garbage collector plugin was at guilt

    Thank you, it's working!!!!!!!!!!!