Theme can not be enabled

Hey Guys,

I'm totally new on Elgg that's why I'm not really into it yet. But I have to say that so far Elgg is just a fantastic Script. I was working with lots of CMSs like Typolight, Wordpress, Drupal... all great Scripts but Elgg has a different concept an fits my needs perfectly.

I've just one problem when getting it started. I can not load themes! After I installed Elgg there's only text shown without any graphics so I thought I have to install a theme first of all. After I uploaded it and went to the Tool Admin the Theme is shown in the list but there's no "Enable" Link like at all the other Plugins. Anyone an idea how to solve this issue? Thanks so far!


  • Hey Guys,

    I was able to fix the problem myself. I just clicked "enable all" and it worked. But I still don't understand why... :)

  • Hi Eichi..

    Ok, by the sound of this, something went wrong with either the installation or configuring the settings.

    Here are somethings that we need to know:

    1. Elgg has a core theme, therefore, no need to install any other themes to start with. Once it is installed, all that is left is to configure the settings with the correct paths..etc. (This could be the problem for why no images or styles where picked up).

    2. Before installing any themes, or even modifying the core theme, it is best to run a test on the site and make sure all is working ok, then you can go ahead an install additional themes, plugins.. etc.

    3. The problem with the enable/disable feature could be related to installing the theme itself, more likely the 'start.php' file, especially if you changed the name of the theme.

    If you feel that the problem may be a major installation problem, do a fresh re-intall and ensure everything is done correctly and let us know how you go.


  • I think carlos is right.

    You shouldn't have needed to install a theme. If I was you eichi I'd suspect that something was not right with the installation and be tempted to install a fresh elgg from nothing.

    It may be a pain but it's better to have a solid install before investing any more time in my opinion.


  • I had the same problem. Don`t know why it happened. The pathes had been correct. But after enabling all, it worked. That`s the main thing.

  • Hey guys,

    I have to dig that topic up once again. I now learned how to work with elgg and I want to create my own themes now. Therefor I set the script up once again so i can begin at the beginning. I follwed the manual exactly but I have the same problem I had the first time installing elgg. This is what I did so far:

    - Created a "data" folder and a "html" folder (as it is suggested in the install.txt)
    - Uploaded all the files into the html folder
    - Launched the install.php (database creation didn't work so i gave CHMOD 777 to install.php; then it worked; database is running, elgg can be administrated but there is still no default theme enabled)

    You can have a look at it here:

    I'm pretty sure that the server configuration is responsible for my problem. Any idea what I could do?

  • I had the same problem, see my post  and can be of some help, I got to install the website, thought there is some link that does not work well yet.

  • I'm sorry, but I think the link you posted deals with sth. completly different. Elgg works correctly only the theme is not shown.

    Another issue in the same context (already mentioned in the first post): If I install a custom theme from I have to click "enable all" so that it's working. If I try to enable just the theme there is no "enable/disable" link shown only a little "-/+" that doesn't change anything when clicking.

    So are there some other ideas?

  • Eichi.. Reading through and looking at your site gives me a feeling that the css file is not being picked up.

    1. Open the css file and ensure that it has content.

    2. Upload the css file to your server again.

    3. Refresh you cache (admin>>site admin>>untick 'use simple cache>> save>> tick 'use simple cache' again>> save)

    See if anything changes.


  • Hey Carlos!

    The idea with the css file seems to be pretty suitable but I wasn't able to solve the problem.

    I checked the css.php (everything's fine) and refreshed the cache. Nothing changed. Still any other ideas?

    What I was wondering is the following: Any normal theme can not be loaded (there is no "enable" link shown and if I click enable all only the logo changes) but this theme ( changes something on the elgg core and then it "nearly" works (I still have to click "enable all" to activate it). Also other themes can then be loaded but are not shown correct. See it here ( on another installation.

    What could be the statement for this?

  • Two thoughts.

    Firstly, Eichi, you say you "created the html folder as told to"? What html folder?

    Secondly, I seem to vaguely recall people having issues installing to a subdir on a domain. Have you configured your elgg to run in a sub-directory? As... it is currently. (IE, rootdir/elgg/html/ as opposed to what mine is, which would be just rootdir/).

    I think you got confused by the manual telling you to put it in your "http_docs" or similar. That's just the world-viewable dir for the web server. You shouldn't have had to create a directory at all.