Avatar Photos working, all other images not working

Before I get started with my issue I have to make known what my setup is and I have read a few of the other topics with similar issues but I have not found a solution yet.

For a few months all images were working.  For some reason or another only a few Group thumbnails and profile pictures were working.  Out of frustration I removed and re-installed Elgg (latest version at the time of this post) and all mods including Tidypics Photo Gallery 1.8.0-rc1.  Avatars are working but any other images for Groups, Photos, etc., are not.  

I own and run my own server so I don't use a web hosting service.  It runs Debian Server, has 12 GB of RAM and a 73 GB Hard Drive.  I have Apache 2.2.16, PHP 5.3.3-7 +squeeze15 and use Webmin for almost all server operations except FTP.  GD is installed and running.  Data folder is located outside of the Elgg directory (it's actually located at /var/www/data/ for technical people).  

I monitored a few image uploads by checking the file system in Webmin and noticed that the files are not being uploaded for Groups and File directories.  I also noticed when I tried to upload a photo/image for Groups or for a Photo Album that a directory would be created but no files would be uploaded.  

I know there is a conflict somewhere and I ran out of options on where to look.  Yes...Elgg is set to the proper Data folder's directory.  I am turning to those here who might have some advice.  Oh...and my PHP ini files are set to allow 256 MB uploads since I have the space for it.  Here's a copy of what my PHPINFO returns:

GD Support enabled
GD Version 2.0
FreeType Support enabled
FreeType Linkage with freetype
FreeType Version 2.4.2
T1Lib Support enabled
GIF Read Support enabled
GIF Create Support enabled
JPEG Support enabled
libJPEG Version 6b
PNG Support enabled
libPNG Version 1.2.44
WBMP Support enabled

Hope this helps.  Any advice would be appreciated.

  • Whoops...site is here


    Just noticed Captcha images are not working either.

  • Tidypics 1.8.0-rc1 won't work with Elgg 1.8.15 anymore in general (you still can upload images to existing albums but creation of new albums and uploading images to them will fail). Try this newer version instead: http://community.elgg.org/plugins/1194049/1.8.1beta6/elgg-18-tidypics.

    While this version of Tidypics should work on Elgg 1.8.15 in general the problem with image uploads on your site might still be caused by something else (especially since group avatars also do not work). I remember that there was mentioned a conflict with a 3rd party plugin in connection with group profile images. Unfortunately, I don't remember which plugin caused the problem at the moment (and maybe this has been fixed in the meantime anyway). I would suggest to test group image upload with all 3rd party plugins disabled. Then you should know if the problem is caused by a plugin and you should be able to narrow down the conflicting plugin then.

    You mentioned you increaded upload limit in php.ini. Did you also increase the limits in Elgg's .htaccess file? This might be the bottleneck. You might also try uploading a very small image to the files section of your site. This way you can better judge if any limits of post size / upload file size / memory limit might cause the upload of images to fail.

  • P.S.: captchas not showing might indicate that there is a JS issue with a plugin on your site. Check if you have installed the latest available version of all plugins installed. Also, check what happens with 3rd party plugins disabled. Does the captcha show up then? If yes, check if the image upload works then. Maybe all problems have the same origin, i.e. a buggy plugin.

  • Images are being uploaded now but are still showing up as a missing image in Elgg.  Yes, I increased limits in Elgg's htaccess file as well.  I'm not too worried about the Captcha at the moment.  I'll go through and disable other plugins I've added to see what happens.  Thanks in advance for the help. 

  • I just went and disabled all plugins I added and images are working.  I will activate plugins one at a time to find out which one it is and post it here for others to take notice of.

  • Found it!  The plugin Did You Know? 1.0b was the cause.  I'm not too worried about updating that plugin as I don't really need it but thought it would come in handy.