New Plugins not showing up, moved Plugins still appearing

Hi all. First time user and poster here. I've tried searching but I couldn't get the answers I needed.

My plug-ins aren't showing up in the plugins list on my site. I placed them in the "public_html/elgg/mod" folder. Additionally, just to check, I moved the "blog" plug-in but it still shows up on my site! Boy am I confused. I have deleted my browers memory, cache, all that jazz and I've logged in and out countless times. Please help this very new player in this game.

I have many plugins I will add but currently the ones in question are: Advanced Statistics and Elgg Update Services


  • Is it only the new plugins that aren't showing up?

    I would start by checking the file permissions for them - if apache can't read it then it effectively doesn't exist as far as elgg is concerned.

  • I've been making a couple of plugins lately they all showed up fine except for the plugins i tried making today. I gave mine a custom category which does show up in the dropdown list on the plugin backend page, but when I filter it shows nothing.

  • Wanted to let you know that I fixed my problem by renaming the folder of my plugin to something else. Apparently the word 'adverts' is reserved or something?

  • Not that I'm aware of, but maybe you're using adblock plus or some other extension that would remove a div from the DOM based on class/id

  • Hi guys! Matt, the permissions are fine. It also doesn't explain why plugins I've taken out still show up :( This is confusing.

  • If you're using adblock then it could be blocking the specific div that shows the plugin because of the adverts keyword.  This wouldn't affect any other plugin.

  • A plugin which folder was removed from the mod directory still shows up?

    Seems to me that the database of your site might be damaged. Check the database for example with phpmyadmin. It should report if there are any tables corrupted and might be able to repair them.

  • oh, I missed the 'removed plugin' part.  Yeah that's odd.  Follow iionly's advice and check your db

  • Matt, no, I don't have adblock, unless it comes with the installation. This is a fresh install, so just the bare basics are there.

    iionly, I checked with phpmyadmin and it didn't mention a thing about corrupted anything. In fact, a bluehost customer service rep. installed it for me (as I was having trouble with Elgg not showing up in my database- now it shows up with the new install).

    Very weird. You guys are very sweet, I appreciate your work and concern. I wish I could give you more info to settle this problem.