Share your php.ini

i'm having trouble with uploading avatars.

i don't have a php.ini or the knowledge to create one.

can anyone share their php.ini file or php5.ini file?

i'm trying to fix this fatal error memory issue.

  • You already have one, or php wouldn't work at all.

    what's the error?

  • @Matt Beckett

    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 13824 bytes) in /home/content/.*/.*/html/engine/lib/filestore.php on line 141

  • try changinge your memory limit to 64M

  • what i ended up doing was .. i did a test.php

    to she me where my php5.ini was

    <?php phpinfo(); ?>

    then i did a test2.php

    <?php echo nl2br( file_get_contents('/web/conf/php5.ini'));?>

    copied and paste it to a new file named php5.ini that i manually put in my root derictory

    and then i erased all my system process which researched for php5.ini and i was able to

    change the derictory

    now, this doesn't change the problem but i changed

    max_execution_time = 60

    so if the user uploads a big file then he'll have to wait a minute ( this won't show the error ) it'll just give him a " Timed out"

    in the end the user should know his file is to big because it either A : took to long to upload or

    B: timied out

    BTW before the user uploads an avatar 

    i changed the en.php in language from "Upload avatar" to "Upload Avatar - File size must be less than 5mb"

    Truth being that there is no restriction but the avatar won't upload

    ... from what i've heard that not a fix lol

    any other ideas?


    my htaccess has been at 64m - i think i can put it to 128m but it will still have the same problem.

  • did you change memory limit in your php.ini file? 

  • Change your memory limit in php.ini and restart the apache..

  • did that too.

    i'll try it again when i go home.

  • 64MB is plenty.

    Have you tried disabling any plugins that might affect avatar uploading?

  • Do you see anything in your logs regarding a mod_fcgid? I always get that error on Ubuntu server when I first start uploading images over 100kb. Can be fixed by setting MaxRequestLen in vhost config


  • @Matt Beckett

    i did that. I even disabled the default plugins like messages friends and such.

    @Mark - nope.