Private Messages Error after I upgrade from Elgg 1.8.9 to 1.8.12

Alright, so I finally have my first real issue. I deactivated all my plugins except Lees Site Offline to disable the Elgg before I copied over all the files, renamed the new .htaccess file and uploaded it, then ran the upgrade.php. Everything was fine, upgrade done. After re-activating all the plugins, I notice when I click on my inbox to check my messages, it redirects me to the main page and I receive an error message that says this:

Warning: The Page Owner 0 is not accessible!

Any ideas how to fix? I tried to disable the messages plugin, didn't work, deleted the messages plugin from the mod folder and re-uploaded it, enabled it and ran the upgrade.php again, didn't work, same error message, thanks for any help.


  • Do you have a backup of your elgg network? You must disable all third party plugins.

    You had two plugins enabled:

    -Liang Lee Site Offline

    -Liang Lee Framework (If not active, the Liang Lee Site Offline would not work)

    So, probably that's why the upgrade went wrong. Roll back to previous backup and make the upgrade proccess again.

    Rodolfo Hernandez

    Arvixe/Elgg Community Liaison

  • if ' deleted the messages plugin from the mod folder ' --> impossible to get that error message !

  • Run upgrade.php with at least the bundled plugins enabled. (Unofficially speaking: it should not do any harm if you don't disable any plugins at all - but this is only by my experience and it could fail for any 3rd party plugin I've not used myself yet).

    Is the issue with the messages inbox the only thind that does not work anymore after the update? If there are other things failing, too. It might be something connected with .htaccess. Had you modified the .htaccess of your Elgg 1.8.9 installation - for example changed RewriteBase? If you have replaced your .htaccess with the default htaccess (htaccess_dist) and not added your modifications again, it might explain your issue.

    Or, are you using any 3rd party plugin that enhances the messages features or changes anything of the bundled messages plugin? If yes, this plugin might not be fully compatible (i.e. not working anymore) with Elgg 1.8.12.

  • I disabled all plugins again, and noticed with just the bundled ones the messages work fine, so its definetly a incompatible plugin somewhere and I just need to figure out which one it is and I guess enable them 1 by 1 to figure out which is causing the issue. Thanks for the help.

  • I've been having the very same problem over the last half hour. I discovered that it is the Liang Lee framwork that is blocking access to the messaging screen. I haven't worked out a solution yet, other than to disable the framework. 

  • The issue is with: Liang Lee Framework 1.1.4 I do not get the error if I disable the framework, but now all of Lees plugins won't work.

  • The problem seems to be that the developer has defined a load of php constants in the 'LiangleeFramework.php' file that are screwing up inbox.php on line 10 and not recognising you as the page owner:

    $page_owner = elgg_get_page_owner_entity();
    if (!$page_owner) {

    If you disable these 4 lines of code in the framework:

    define('lee_pown_entity', elgg_get_page_owner_entity());
    define('lee_pown_entity_guid', elgg_get_page_owner_entity()->guid);
    define('lee_pown_entity_name', elgg_get_page_owner_entity()->name);
    define('lee_pown_entity_username', elgg_get_page_owner_entity()->username);

    then it will temporarily fix the problem. These constants aren't being used in the admin_panel or block_users (you will need to check your others) .. so it solves the problem for me at least. 

    I'm looking at a way to seperate the block user code from the lianlee framework as it all seems a bit messy for my liking. 

  • I accidentally got this page owner 0 error when I put elgg_get_page_owner() in my theme's start.php and forgot to remove it when I was making custom functions.

  • @rjcalifornia - Yes, I had the framework activated and ran site offline mode when upgrading elgg. To use his plugins the framework has to be installed.
    @DhrupDeScoop - I had deleted the mod folder 'messages' and re-uploaded thinking maybe there was a corrupted file causing the problem, was just a shot in the dark, but didn't work.
    @iionly - Thanks, you helped me figure out which plugin was causing the issue, or actually the framework.
    @ne0nblade - Are you using the latest version of elgg also? I had no issues with the framework before the upgrade, and then actually I upgraded to his latest version of the framework, and thats when I had the prob.
    @Cim - I've never seen this error before, thought maybe I did something wrong on my end during the upgrade, but glad I didnt.

    I have notified Liang of the problem, I had upgraded elgg, then upgraded to his latest version of the framework but for now his framework is deactivated so private messages can be used.

    I'm sure he can fix the issue pretty quickly, then I can just upgrade the framework again so private messages will work with all this plugins. I use alot of his stuff, he and his crew are very good. Thanks for the help you guys.

  • Hi there I am a Lee's team member i used his id a while. Actually i am new to elgg i have used define() function in LiangLeeFramework lib. I have called a Lee on his phone for this problem he said using a elgg_get_page_owner_entity will cause this error so i removed that code and released a new of version framework.

    Lee is not here his wife given birth to baby he is at UK. Any question for Lee drop a message at his email