languages and system cache issue in elgg 1.8.12

when system cache is turned on elgg only see english language. Others languages translation are not shown anymore in Languages Setting: if the system cach is off i can switch with no problem between English and French. When the system cache is on if i select english language then the French Language selection isn't shown anymore in the Languages Setting option.

i thought this pb was resolved in the 1.8.12 version.


  • On the arvixe intall i succeed to have English an French now with system cache on..but when i select english it stays in english...i have turned the cache off but now my web site doesn't work properly anymore...times to times (nearly each times) scritps doesn't load properly anymore now :(

    i have with type of error in firebug:

    "NetworkError: 500 Internal Server Error -"
    "NetworkError: 500 Internal Server Error -"
    it used to work perfectly with the cache off :(
    and sometimes the css as well
    "NetworkError: 500 Internal Server Error -"
    I m lost...
  • did you try running upgrade.php when changing languages?

  • yep i have tried...

    but i have just toggle the language from French to made the script works (but in the english set up displayed french), back to french and the script works again..system cache off..

    I m going to keep it that way on line..and experiment with a new elgg test installation on arvixe with one fr.php see if it works with none of my plugins and addmy plugins one by one....

    I will let you know...thanks for your help..

  • Do you get the error with cache on or off? I'm not sure what you meant. The 500 error could be due to too many http requests and/or mysql queries for the Apache or MySQL server to handle at times when the cache is turned off.

    The site language is not necessarily the "user language". If you change the site language as admin, it might not change the language of the site as your admin's user language is still the default language (English). Only logged-out site visitors and new users will see the currently selected site language automatically. For existing users their user language selected in user settings will override the site language setting.

  • thanks this is true for the site language. i have turn the cache on , flush it , upgrade: i still have the 500 (something i haven't a month ago when i installed my site with the cache off and no i can't get rid of it). As a registered user (the cache is on) i have switch to english language: it works. No i want to ga back to French language, the option is not anymore in the select. i have to turn the cache off to get it back. I turned the cache off and now i can select French. still with the 500 error ( i m waiting for the arvixe support answer).

    still on Arvixe with th cpanel i have created an add on test domain: created a new test db, a new data folder unzipped elgg 1.8.12. after installation i had written manually a fr.php from the en.php of the plugin group...just that and i have the same pb with the language selection. As described above same issue on my computer on localhost..tested with other computers at different place....

    I m going to try now on my test Arvixe domain to install elgg 1.8.3

    and for my main domain for my business site i m thinking of reinstall elgg 1.8.12 keepng the same db to not lose my registered users (i m not going to get rid of this cache pb but maybe i ll get rid of the 500 error and have my website at it was before working without system cache on...)


  • Can we break something in the db or on the install by switching "too roughly" (without disabling the plugins ) between two mod folders containing different plugins ? in the admin there is some warnings saying that some plugin cannot be found etc...

  • ok now on Arvixe on my main domain i have my web site running with elgg 1.8.12: the language select doesn't work with the cache on.

    on the add on domain i have my website running with 1.8.3: the language selection works with the cache on.

    I don't know what to think :/

    And in both case i have some 500 error concerning the loading some script or some pics or some css sometimes i have the page loaded without the 500 error: but i think that this is another works perfectly during a month without any pb.

  • With Elgg 1.8.3 the language files were not cached. Language files are cached since Elgg 1.8.4. That's the explanation regarding having no problems with language selection in Elgg 1.8.3 but of course it does not explain why you have problems with language selection in later version.

    I still think the issue is less likely an issue of Elgg core (as you seem the only one having this specific issue) but somehow caused by either your server config, the plugins you use, the language files itself or a combination of it. The fact that you get these 500 errors is a sign that something is surely not working correctly. If the language selection issue is also due to the same reasons... I don't know. I have to admit I'm slightly lost about what you exactly tested on which installation (your productive site, a fresh install etc.). At one point you said the site language can be changed back and forth correctly (the fact that the site was still displaye in the original language is solely due to the admin user language setting - or did you try by creating a new account or by looking at the site while logged out too?).

    Later on it again didn't work to switch back to the original . What was differenent then? You need to compare the differenences in the installations to narrow down the root of the issue. If necessary you need to repeat the testing several times until you know.

  • thanks for you help.

    this is the situation:

    with a fresh install of added plugins the elgg default ones: i m just adding a fr.php file in the group plugin (for exemple)...this fr.php file is written by hand in netbeans (UTF8)...

    then i m logged as a user, in the settings user account (not admin) i switch from english to pb then if i switch back to english no pb this point i cannot switch back to french....

    same result on localhost install and arvixe install (in both cases it is the fresh elgg install without my plugin just the fr.php added)....I remember now that i have turn on the output_buffering in my php.ini can it be that ? I have put it back to off but it didn't change anything...I should inquire in this direction maybe ?

  • I'm not sure if output_buffering makes any difference. On my local test server (i.e. the computer I'm just sitting in front of) there's output_buffering set to 4096 in php.ini. So, it's used and I haven't noticed any issues at any time.

    Let's try something different:

    I've done some testing and I think I maybe managed to reproduce your issue. You mentioned earlier that you don't use any language pack you've downloaded but installed only a few language files created by yourself - in the simpliest way by simply renaming en.php to fr.php and adjusting the array name in the file accordingly.

    So, I did the same for the groups language file... and the French language was not even selectable! I got an idea then!!! Next I downloaded the French language pack for Elgg 1.8.3 from here (I don't speak French but I wanted to have some real French language file). I then installed only the groups language file from the French language pack. Finally, I got to see French as seletable site language but when I turned on site caching it vanished again!!!

    With only the French language file of the groups plugin installed the language completeness of French was shown at ~9.5%. Next I installed also the main Elgg language file to bring the completeness up to ~44%. Now, it seemed to work without issues regardless of site cache on or off. I could switch between languages both in the site settings and also when logging in as normal user and changing language in user settings.

    So, I suspect the following (but I have not yet found out any hint in Elgg's code why this should be the case): if the language completeness is too low selecting this language is either not possible at all (see first test with an "identical" french langauage file for groups plugin) or you get at least a problem with changing the language when site cache is turned on.

    I would suggest for you to download the French language pack here from the site and to install at least the main language file and a few others - the larger they are the better - to bring up the language completeness up to at least 40-50%. I'm looking forward to hear from you, if this might solve the issue for you.

    It's a pity the French language pack is on Elgg 1.8.3 level still. So, you would not get a perfect translation of everything. But you could at least use it as starting point and add the missing strings/correct any changes. It should not break your site when using outdated language files but it surely is not a long-term solution.