Unformatted problem, no css?


I have been trying forever to install elgg onto my media temple hosting, I have even upgraded to a dedicated virtual in hope.

I have managed to install it however I seem to have no styling which leaves it almost useless. Here is a link:


Does anyone have any ideas? I have check that I have all the needed tech requirments:

PHP Info:




  • did you tried to install elgg with another data folder path?

  • Hey everyone,

    Seems like I have got it working. I'll be honest I'm not quite sure what the issue was but I re-inatalled Elgg with a new database and this is what I did different.

    • I uploaded Elgg into my desiered directory
    • Before going through the installation screens I uploaded my completed settings.php file
    • Then I renamed htaccess_dist to .htaccess rather than using the one that gets created during the installation
    • Then I loaded up the installation and filled in the fields and like magic it worked!
    So I think that the issue was with the .htaccess file in the end as this is the only thing I could imagine would have made the most difference.
    Thank you to everyone who helped out with suggestions, I hope I can repay the favour to the Elgg community at some point!
  • HI All,

    I have this problem too. I put my install on a subdomain and it just wouldn't work. I deleted everything, started again with a fresh install in fresh databases but it still refuses to display any css styles.

    I've tried checking the database in phpMyAdmin, I've checked .htaccess and it's got the right contents - and as I can navigate the site I assume it's working.  I've checked my setting files, I've ran upgrade. Nothing seems to work. 

    I'm totally lost as what to try next, would be very grateful if anyone has any ideas?  I don't mind setting up a fresh install (already lost all my work so I'm starting from scratch) but I've done that twice now and it doesn't seem to help.



  • Do you have to have it in a sub domain? seems like a lot of trouble for 99cents it would cost you to buy the cheapest domain (dot info)

     Css is cached and sometimes the cache can cause problems. Did you try running /upgrade.php.

     Having never worked with subdomains with elgg I cannot advise you much, I'm trying to think of what I would do. What type of hosting do you have?

    Can you still sign in? if you can it would means that your installation is mostly right

  • Hi Jack,

    Thanks. I can sign in, it seems functional just unstyled.  It is in a subdomain, yes, I could pop it in a directory under mydomain/elgg if that would be easier?  The hosting is fully featured as it's a dedicated server that the tech guys from work run for me. I'm scared to let them touch elgg though as they aren't familiar with it. 

    If a subdomain or directory won't work I will buy a new domain, thanks.


  • I've tried this in a subfolder instead of a subdomain but I still get the same problem.  Quite bizzare!

  • drop a link to your site so I can take a quick look

  • Sorry, Jack, only just saw this - I have it running again now, there was a corrupted file in my install. (whoops!)

  • Hi there

    I have exactly the same problem ... after installing everything seems to work despite css. If i deactivate simple cache the layout will be shown ...

    my site is here: elgg.idotter.ch/elgg

    how can i install elgg in root directory when /data/ mustn't be in installation path?