Only Companies Plugin but for 1.7 need 1.8 !!!

http://community.elgg.org/plugins/717152/1.7.0.0/hypecompanies-17?annoff=25

Would love to see a updated version of this plugin for 1.8 anyone interested in converting really could use it!!!