Elgg Blog: Elgg 1.10 will require PHP 5.4

We encourage you to talk with your hosting provider to make sure PHP 5.4 support is available so that you can stay up to date with the latest and greatest of Elgg.

I just merged the pull request that bumps the Elgg 1.10 requirement to PHP 5.4.

There are two main reasons for this switch:


  1. PHP 5.3 hasn't been getting security patches for a while now. It's not safe to continue using it and it isn't responsible for us to continue supporting it.
  2. PHP 5.4 has new features we think would streamline development for us and for plugin authors.
PHP 5.4 has less than 1 year of support left. You should expect that we will bump the PHP requirement to 5.5 by the time that support expires for similar reasons.
Note also that you don't have to hold yourself back! Elgg works just as well with PHP 5.6, and we always encourage using the latest version of any software when possible so that you can be confident you're getting the best level of support.


Evan Winslow

Software Engineer at Google. Elgg enthusiast. I wrote the Javascript and CSS frameworks for 1.8.

Latest comments